Sign-in / Sign-up
Your question

Existing OS on SSD - adding a separate RAID 5 array, having some trouble.

Tags:
  • NAS / RAID
  • Controller
  • Storage
  • Motherboards
  • SSD
Last response: in Storage
December 16, 2013 9:47:47 PM

Hey all. I've done some searching around trying to figure things out, but frankly I am enough confused that I don't really even know which pieces of advice apply to me.

Full hardware setup here: http://pcpartpicker.com/user/RyanCoonan/saved/31Jr

So I put the computer together without the HDDs inside, only the SSD. I installed Windows 7 Home 64-bit on it. What I want to do is add the four HDDs and put them in RAID 5, using the on-board RAID controller. Here is what I tried to do (after physically connecting the drives):

1. Opened BIOS, changed SATA controller settings from AHCI to RAID.
2. Opened RAID settings, selected the four HDDs and put them in RAID 5, leaving the SSD as "non-RAID disk."
3. Windows would not boot.
4. I changed the SATA controller back from RAID to AHCI.
5. Rebooted, Windows booted fine.

Now, what I assumed was that when I opened up Windows Explorer, I would see either a) just the SSD or b) the SSD and all four HDDs as separate drives. It was case A. However, when I opened up the disk management tool, I was surprised to see that it actually saw the ~12TB RAID 5 array. I formatted the disk, and everything seemed fine. However, upon copying a test file (~700MB) from the SSD to the array, it had a transfer speed of about 2.5 MB/s. Clearly something is wrong.

What do I need to do to have my OS running on the SSD, and the four HDDs in RAID 5 the proper way? I am new to RAID, this is my first time trying it. Every answer I have found online seems to assume that I am wanting to install the OS on the RAID array, or copy the OS to the RAID array. I was hoping it would as simple as setting up the RAID in the RAID BIOS thing, then booting up. Why couldn't Windows boot when I had the SATA set to RAID?

EDIT:
I went back into the BIOS, and tried changing the SATA setting back to RAID. I then went into the RAID config. It only shows three of the four HDDs and says that the RAID is in a degraded state. I deleted the RAID. Upon going back into the BIOS, I see that it only sees three of the four HDDs.

I was able to fix that by disabling and re-enabling the SATA ports. So, now I see all the drives again, and we are back to square one.

More about : existing ssd adding separate raid array trouble