Solved

Corsair Dominator Platinum CMD32GX3M4A1866C10 Kit not working on Intel DH87MC

I've purchased Corsair Dominator Platinum CMD32GX3M4A1866C10 32GB kit (4x8GB modules).
Problem is when I installed the kit in MB and power on the system, system right after booting shuts down and then restart automatically and keep on doing it with no display. I removed two modules and power on the system, it worked just fine. I've checked all the 4 modules using two modules at a time and system worked but problem persist with all 4 modules at a time.

Any help.

System is:

Intel DH87MC
Intel core i7 4770
EVGA GeForce GTX 660
PSU 550 W
4 answers Last reply Best Answer
More about corsair dominator platinum cmd32gx3m4a1866c10 kit working intel dh87mc
  1. Best answer
    Couple of suggestions, first update the bios and see if that fixes the problem. Most boards ship with an older bios and a lot of time big memory support isn't on them... If that doesn't help your problem see if enabling xmp in the bios helps things.
  2. your motherboard supports "DDR3-1600/1333"

    but ur RAM Speed is 1866
    try to reduce the RAM frequency .....
  3. gokul36 said:
    your motherboard supports "DDR3-1600/1333"

    but ur RAM Speed is 1866
    try to reduce the RAM frequency .....


    It wouldn't default to that speed and he didn't mention enabling xmp, and either way if it works with 2 of them it should work with all 4 if the kit is good.
  4. After installing the RAMs, MB defaulted to 1333 MHz I checked it. However, it is no longer giving me XMP option rather Manual Settings option and Auto options are now shown. I've checked with Release notes of bios update version and none of the notes seems to cater for the memory issue.
Ask a new question

Read More

Platinum Corsair Dominator Intel Memory