Solved

Computer won't turn on after installing a new power supply

From what I can tell everything looks like it is plugged in properly. During the installation I accidentally unplugged the front panel cables but I am confident they are in the right place. I tried the paperclip trick to see if the power supply is faulty or not. Nothing happened to the power supply, but the lights in my house flickered (maybe just a coincidence). Also, when everything is plugged in and the power switch is on "I", there are no lights on. Normally there is a blue light on the motherboard.

The power supply is a Corsair HIVE-750

Here is a link to my motherboard: http://us.msi.com/product/mb/P67A-G45--B3-.html

Processor: i7-2600k
Graphics card: GTX 580 Twin Frozr II

Any help is appreciated
6 answers Last reply Best Answer
More about computer turn installing power supply
  1. Perhaps plugging it into the wall socket might help.
  2. You're kidding, right?
  3. Best answer
  4. Kr8er said:
    You're kidding, right?


    Yes, I am kidding.

    But you would be surprised what people miss sometimes.
  5. Was the fan spinning on PSU when you did the paperclip test ?
  6. I have a Dp67bg Intel Motherboard and an intel i7 2600k. I had my pc running overnight and when I woke up my router wasn't powering up and neither was my pc. Apparently there was a thunder storm. I pressed my pc power button and nothing came on. no fan spins or beep noises. So I replaced the power supply and tried the power button again but still theres no sign of power, Usually my mother board has a blue light that gets lit up as long as my pc is connected to power, now im not sure what could be blown or broken? anyone had a similar experience?
Ask a new question

Read More

Power Supplies Motherboards Light Computers Front Panel Components