Solved

Gskill ram stopped working

Hello.
I purchased gskill ripjawsx 4gb(2x2gb) ram online. .but few days later one of my ram stick stopped working. . My pc shows only 2gb of ram. I checked in bios it also shows 2048mb of ram. .i tried booting up pc with only 1 stick and i found that 1 stick is not working, . Its just a few months old and in warrenty. .i havent heared any type of beep etc. . So will gskill repair this? Since gskill service center is so far away from my home. .so is there any easy method by which i can repair it in my home, thanx
5 answers Last reply Best Answer
More about gskill ram stopped working
  1. Best answer
    RMA @ http://www.gskill.com/en/rma

    Just post it to them.
  2. They have a lifetime warranty, have you tried just running the supposed bad stick by itself in the same slot that works with the other stick, could still be a board issue if not
  3. Ya i have tried running it by bad stick. .it doesnt boot at all
  4. They are RMA centers in China (Taipei), the US (california) and Europe (Netherlands)
  5. But i am from india. .and there is no service center near my home
Ask a new question

Read More

BIOS RAM Memory