New mobo wont recognize old hdd

Hi guys,

I just got this new Asus H87M-Pro and have just finished setting it up with new a CPU and RAM and everything, but I noticed it doesn't support old flat cable hdds, which meant I had to go and get this IDE/SATA TO USB 2.0 hard disk adapter for my Windows(!) hdd (which is the old one).

Problem is, it (BIOS) isn't recognizing the darn thing! Only my newer, small cable (SATA?) hdd and my disk drive. Both the adapter and hdd is powered and spinning but that's it.
I tried switching cables, using an external power supply for the adapter instead of my front USB bus and really squeezing those cables in properly but to no avail.

I've looked around a bit, searching forums and stuff, and the only thing I can think of atm is that, like other plug&play things, Windows needs to recognize them in Device Manager... but I can't access Windows. I've managed to run Windows system repair twice but it didn't do any good.

Please help if you can. 'Tis not the season for this kind of frustrations. :(
6 answers Last reply
More about mobo wont recognize hdd
  1. I would mess with the drive jumpers a bit and try a few different settings.
  2. RealBeast said:
    I would mess with the drive jumpers a bit and try a few different settings.


    I tried changing the drive from 'Cable Select' to Master (using this reference) but it didn't help. Sadly, I don't have more jumper thingies to play around with for other settings.

    Other things I've tried is placing the SATA cables in the same bus station on the mobo and switching HDD LED on front cables.

    Nothing so far but thanks for contributing. :)
  3. It would have been master or CS so theres no need to try the others.
    In your bios, make sure the sata port is set to IDE or Compatibility mode.
    Once you do that if its still not detected try the other jumper setting (Master/CS)
    If you still have problems we'll need to know which motherbd you have and which adapter you bought as not all of them support harddrives.
  4. Hmmm, I'm not sure that I have that particular option in BIOS. I run an ASUS H87M-Pro motherboard and all I can seem to fiddle with SATA-wise is setting SATA Mode Selection to AHCI, RAID, Disabled or, most interesting, IDE.
    Then I can pick IDE Legacy or Native Mode, but it still doesn't the hdd on the list below the options. Perhaps I should try the jumper with this on again... or did you mean some other option entirely? :S

    Thanks for the informative suggestion. :)
  5. Yes those adapter boards work with either the drive set as CS or as Master so if one jumper setting doesnt work then try the other. If neither of those works then try the other IDE setting in the bios and again try the other jumper setting if it doesnt work.

    Please know that you have to do a full shutdown to change the jumper setting. You cant change it in mid-stram. It only gets read at startup.
  6. Thank you, I tried all possible setups, I reckon :x, but to no avail.

    IDE, AHCI, RAID, Native, Legacy, Aggressive LPM Support, S.M.A.R.T. Status Check - I believe I tried them all.

    I'm beginning to think I'm bound to either install Windows on my other hdd or get a new one entirely :3
Ask a new question

Read More

Windows Storage Hard Drives Cable