Sign in with
Sign up | Sign in
Your question
Solved

Unable to Load Pages While Downloading

Last response: in Wireless Networking
Share
December 25, 2013 4:52:55 AM

I've got a new desktop which is connected to my home wifi using an USB adaptor. The signal quality is constantly at 5 bars but I find myself frequently having to refresh multiple times whenever I load a new page on the browser either because it's not loading or pictures or not showing. Pages become near impossible to load when I am downloading stuff(torrents, upgrades, games etc). Also noticed other computers in the house are affecting mine when they are in the process of downloading files. Torrents, updates be it through mine or any other computers in the house all make it impossible for me to browse the internet. Pages literally refuse to be loaded at all whenever something is downloading. None of the other computers are affected however.

The connection also doesn't actually disconnect at all from the wifi when downloading but web pages are just not loading. I literally had to click refresh a couple of dozen times when I'm trying to load a page during a download and even then, sometimes it wouldn't come up. What is strange however is that I'm having no issues with downloading bigger files such as direct downloads, windows update, steam game downloads and torrents. No drop outs that I've noticed averaging 400kb/s.

Also noticed there are some sites that don't seem to be affected. I don't recall having trouble loading facebook(pictures often unloaded) or youtube(videos not loaded). A forum I frequent (http://forums.whirlpool.net.au/) also has no issues loading. But the majority of sites absolutely refuse to load when something is downloading at the background and often run into issues loading even without downloads running. The moment I stop the downloads, it'll load up much better although some pages still often require some refreshing that is still too much than what im used to compared to previous computers.

Any program that requires an internet access is also struggling to get connected even at times when there are no downloads running. I had to use direct links to install certain programs such as Adobe reader/flash. It's often impossible to check for updates in programs or even sign on to clients like Steam/Origin which requires a connection. I had to try for ages before it signed in online to Origin and even now it constantly struggles to sign on. Steam also have trouble loading images and such during a download.

Everything else in my house including my laptop, another desktop, ipad and phone works fine and are not affected. No issue browsing the net while downloading or otherwise.

Wireless is connected through an USB adaptor plugged into the back of my desktop (i've also tried front USB ports which didn't help). Modem/router is provided by my ISP. It's called a BOB and is a Belkin made model: F1PI243EGau Verson: 1100a. I've tried two adaptors (ASUS USB-N13 and Linksys AE1200) and both of them runs into the same problem. Running windows 8.1 and using ESET NOD32 as an antivirus with the windows firewall turned on.

This is extremely frustrating and has never happened with any other computers I've used before. Any suggestions why this is happening? Would really appreciate any help at all since this has been on going ever since I took delivery of this desktop 5 days ago. :( 
December 25, 2013 5:03:41 AM

try a different browser?
m
0
l
December 25, 2013 5:16:46 AM

sounds like a bandwith issue... like for me i got 56k dialup if i were to do a download its slow if i do a download and try to surf and pull up a web page its slower cause now each thing i do has to share the bandwith.
m
0
l
Related resources
December 25, 2013 5:39:44 AM

Different browser have been tried with both firefox and IE tested. Doubt it's a bandwidth issue since none of the other computers or devices are affected. I can surf the web fine on my ipad/laptop/desktop during any download be it with this computer or others but this computer alone suffers from this issue. It's not even pulling up a page slower. It's simply not loading it. If I refresh it enough, it may come up and when it does, it's instantaneous although pictures are often missing.
m
0
l
December 25, 2013 6:28:21 AM

i guess you have reset your internet options and retryed?
m
0
l
December 25, 2013 6:56:59 AM

Yes.

Someone on another forum suggested it could be a PMTUD blackhole issue. Is anyone knowledgeable enough with networking suggest if that is the case and what I can do to fix it? Would very much appreciate that.
m
0
l
December 25, 2013 10:18:39 AM

you said that it was running wireless how did it work on the hardwire?
m
0
l
December 25, 2013 10:36:08 AM

If the router is set to broadcast on different channels - settings named Automatic or Roaming - and the wireless adapter is set to receive on a specific channel, that could cause this.
m
0
l
December 25, 2013 4:32:38 PM

Saga Lout said:
If the router is set to broadcast on different channels - settings named Automatic or Roaming - and the wireless adapter is set to receive on a specific channel, that could cause this.


I don't think my router is using duo channels. It's fairly old. Care to explain how may I check if the above is the cause?

I'm using channel 6 on my router but I don't see how I can locate or select channels for the USB adaptor.
m
0
l
December 25, 2013 7:25:33 PM

Turns out it was the ESET NOD32 antivirus that was causing the issue. Uninstalled it and everything is back to normal. Now to find a way to have it on without causing this disruption.
m
0
l

Best solution

December 25, 2013 7:53:41 PM

All it took was adding certain apps to be excluded from Protocol Filtering and that solved everything!
Share
December 25, 2013 8:01:34 PM

glad you got it going sorry i was no better help for ya.
m
0
l
December 25, 2013 11:34:05 PM

Well done - it's always nice when you fix it yourself. I've picked your own post for a Best Answer to help others in the future.
m
0
l
!