Sign in with
Sign up | Sign in
Your question
Solved

open batch file in windows 8

Last response: in Windows 8
Share
December 26, 2013 6:36:23 AM

I am trying to run a batch file in Windows 8. When I unzipped the tool I am trying to use, the batch file turned up associated as a PDF, which was useless. I managed to change the association to Notepad, so now I can read it, but it will not run. In previous versions of windows. the association would be "windows bat file" and I would just click and run. But now I can't get it to run. Help please!
December 26, 2013 3:23:01 PM

This may have worked in Windows 7, but not in 8. I tried it and even though Notepad was deleted in regedit, the file is still opening in Notepad. I rebooted the computer after deleting the files I had downloaded, redownloaded and reunzipped. The result was the same. This is a Windows 8 problem, I am certain.
m
0
l

Best solution

a b * Windows 8
December 26, 2013 3:57:28 PM

I would disagree there. This is not a Windows 8 specific issue. Something has changed the file association, and it needs to be changed back. This same issue can be replicated all the way back to Windows 2000 (and probably earlier). Did you check the following keys and make sure they were set to the values shown, as seen in the responses in that post?

[HKEY_CLASSES_ROOT\.bat]
@="batfile"

[HKEY_CLASSES_ROOT\.bat\PersistentHandler]
@="{5e941d80-bf96-11cd-b579-08002b30bfeb}"

[HKEY_CLASSES_ROOT\batfile\shell\open\command]
@="\"%1\" %*"

Edit: To make things easier, I created the reg file for the keys listed above. You can download it from here if you want: https://dl.dropboxusercontent.com/u/96013768/Restorebat...
Share
!