Sign in with
Sign up | Sign in
Your question
Solved

Really need some help here

Tags:
  • Homebuilt
  • CPUs
  • Boot Failure
  • Systems
  • Motherboards
  • GPUs
Last response: in Systems
Share
a b à CPUs
a b V Motherboard
December 31, 2013 2:53:37 PM

I would usually try and troubleshoot myself, but this morning im not really up to it.

Two days ago, my friend and i stayed up all night gaming, and most of the next day(yesterday). I had moved my pc to a different room as there wasn't enough space.

This morning, i have moved my pc back into my room, and reconnected everything properly.

However, when i turn it on, it powers on and doesnt do anything. The screen remains blank, flicking between inputs.

So i pulled out my anti static strap, and:

Removed the CMOS battery, in an attempt to reset it, i dont know if this worked or not though. I also dont know if my board is meant to have a light on it anywhere, but i cant see one when the PC is in standby/ turned on.

Reseated the GPU, and RAM.

I dont know if this is my GPU, or the rest of the system, as i havn't got a second system here to test components with. I only bought the GPU in September and the GPU, CPU and RAM at the start of November, so if its any of these, I will be annoyed.

I have tested the monitor with my laptop using the hdmi cable from my desktop, and its fine.

Specs are as in my profile.

Any help would be appreciated, as getting a tech company to look at this will cost a lot of money in my country.

More about : question

a b à CPUs
a b V Motherboard
December 31, 2013 2:57:51 PM

Have you tested the PSU to make sure it even works?
m
0
l
a b à CPUs
a b V Motherboard
December 31, 2013 3:00:04 PM

well the case fans come on, the cpu fan, gpu fans and hard drives spin up. so im assuming its working. as i said, i have no other parts here to test with at the moment
m
0
l
Related resources
a b à CPUs
a b V Motherboard
December 31, 2013 3:03:59 PM

I will remove all of my peripherals and then reseat the gpu and ram again, to see if i can get it working
m
0
l

Best solution

a b à CPUs
a b V Motherboard
December 31, 2013 3:06:23 PM

bradsctt said:
well the case fans come on, the cpu fan, gpu fans and hard drives spin up. so im assuming its working. as i said, i have no other parts here to test with at the moment


Check the wiring, might have knocked a wire out of place, could be a damaged PSU, as they will boot some of the stuff but not have enough power for the rest of it. Try taking the GPU and use just one stick of RAM to start it and see if that helps too.
Share
a b à CPUs
a b V Motherboard
December 31, 2013 3:09:15 PM

Problem with a FX build using a 970 board, is that most don't have built in graphics, as is the case with mine. So without my GTX 760, i cant see anything. Anyway, i will finish rewiring, and test it again.
m
0
l
a b à CPUs
a b V Motherboard
December 31, 2013 3:23:31 PM

After rewiring and reseating everything for a second time, i turned it on and it booted :) 

Thanks everyone who helped
m
0
l
!