Sign in with
Sign up | Sign in
Your question
Solved

I think my i7 4770k is messing causing drivers to not work properly

Last response: in CPUs
Share
December 31, 2013 9:03:03 PM

I got a new CPU, and motherboard. i7 4770k, and Z87 Killer. I tried plugging in my Blue Snowball microphone, but the driver wouldn't install properly. It would never pop up in the recording list in sound settings. I googled it, and people were saying their plugs were in upside down, but that wasn't my problem. I ended up buying a ASUS Z87 Plus motherboard because I thought it was a mobo problem, but the same thing happens with this one. I have also re installed windows 8.1, and 7 multiple times. With the mic works fine with my brothers computer, and my laptop. I installed all of the drivers on the disc that came with the motherboards. My other specs:
GTX 770
120gb Hyper X ssd
1tb WD Blue HDD
8gb 1600mhz hyper x

Best solution

a c 192 à CPUs
a c 468 V Motherboard
December 31, 2013 9:07:52 PM

http://bluemic.com/snowball/#/support/
have you checked the age of the mic?? per there tech info if it below a set serial number the mic wont work. there also newer software for those mics.
Share
December 31, 2013 9:09:09 PM

smorizio said:
http://bluemic.com/snowball/#/support/
have you checked the age of the mic?? per there tech info if it below a set serial number the mic wont work. there also newer software for those mics.


But the mic works with another Windows 8.1 computer, and worked on my old Windows 7 computer
m
0
l
!