Sign in with
Sign up | Sign in
Your question
Solved

Noob question - Compatible Parts?

Last response: in Components
Share
January 3, 2014 5:00:50 PM

Hi,
This may be a stupid question, but can anyone tell me if these parts are compatible with each other?

MB - ASUS M5A97 R2.0 970 AM3+ R
CPU - AMD 8-CORE FX-8320 3.5G 8M R
MEM - 8G CORSAIR CMZ8GX3M2A1600C9B
HDD - 1TB 3.5" SATA6.0GB/S 64M
PSU - CORSAIR 750W CXMOD 80+BRZ ATX

I'm having trouble with random lag
instances and very very slow log on/off times (like 10-15 mins..) I watched the NewEgg 3 part video about how to build a computer and on part 3, as soon as he installed Windows 7, there seemed to be no lag on his end even without drivers installed. If anyone has had a similar problem or knows what to do please let me know ASAP. I may just try to reinstall the Windows 7 OS if all else fails..


January 3, 2014 5:08:55 PM

Yes, they are compatible
m
0
l
January 3, 2014 5:09:23 PM

Those parts are fine do you have any programs running that would take up a lot of ram?
m
0
l
Related resources
January 3, 2014 5:10:50 PM

Hi,
Was Windows installed on this board?
The components should work together.
m
0
l
January 3, 2014 5:15:28 PM

babachicken said:
Yes, they are compatible


Thank you for the quick response!
m
0
l
January 3, 2014 5:17:41 PM

Krishna Moorthy said:
Those parts are fine do you have any programs running that would take up a lot of ram?


Thank you for the quick reponse! And I haven't installed anything but the drivers and windows updates, because them being outdated was what I thought was the problem. Btw nice profile pic..SG ftw!
m
0
l
January 3, 2014 5:19:07 PM

alexoiu said:
Hi,
Was Windows installed on this board?
The components should work together.


Yes, I did a fresh install of Windows 7 64-bit via a bootable USB. ..I did torrent it so perhaps the version of W7 I dled was corrupted or something?
m
0
l
January 3, 2014 5:21:51 PM

Hard to say. What are the Windows Experience values for CPU, memory and graphics?
m
0
l

Best solution

January 3, 2014 5:22:37 PM

dwhiting said:
alexoiu said:
Hi,
Was Windows installed on this board?
The components should work together.


Yes, I did a fresh install of Windows 7 64-bit via a bootable USB. ..I did torrent it so perhaps the version of W7 I dled was corrupted or something?


NO NO NO NO NO NO NO NO NO NO NO NO:no: 
Not your os :c god knows what nasties might be packaged with it. just go out and buy a copy or get an iso of the microsoft website and run an unlisinced copy untill you can buy a license. http://www.w7forums.com/threads/official-windows-7-sp1-...
Share
January 3, 2014 5:23:16 PM

dwhiting said:
Krishna Moorthy said:
Those parts are fine do you have any programs running that would take up a lot of ram?


Thank you for the quick reponse! And I haven't installed anything but the drivers and windows updates, because them being outdated was what I thought was the problem. Btw nice profile pic..SG ftw!


yea i likes Steins; Gate Mirai Nikki was pretty good to :) 
m
0
l
January 3, 2014 5:29:58 PM

Krishna Moorthy said:
dwhiting said:
alexoiu said:
Hi,
Was Windows installed on this board?
The components should work together.


Yes, I did a fresh install of Windows 7 64-bit via a bootable USB. ..I did torrent it so perhaps the version of W7 I dled was corrupted or something?


NO NO NO NO NO NO NO NO NO NO NO NO:no: 
Not your os :c god knows what nasties might be packaged with it. just go out and buy a copy or get an iso of the microsoft website and run an unlisinced copy untill you can buy a license. http://www.w7forums.com/threads/official-windows-7-sp1-...


Ok thank you, I will try that out and see what happens.

m
0
l
January 3, 2014 5:32:08 PM

seriously just go buy win 7 its like under 100$ :p 
m
0
l
!