Solved

No post, fans on cpu/gpu spin, but no display

Hello,
I recently bought a Biostar a55md2 along with a athlon ii x4 750k and 8 gigs of crucial 1333/9cas

When the CPU arrived today i put it all together, but i dont get any display, all the fans however do spin up
What i've tried---
Clearning CMOS
Taking out battery for 30-40 mins
single stick of RAM in both DIMS(tried with diff RAM aswell)
Made sure everything was properly plugged and seated(CPU power is plugged, 24pin in plugged)
Made sure the PSU works(power other system just fine)

Motherboard doesnt have speaker for beep codes

I've no other systems to put the athlon 750k into

Anything else i can try? Any way to tell if its the motherboard or CPU?

Thanks you.

Full specs-
PSU: Thermaltake tr2
GPU evga 550 ti
Mobo: biostar a55md2
CPU: athlon ii x4 750k
RAM: Tried crucial 1333/9cas and crucial 1866/11cas and some other ddr3 stuff i cant remember the brand/speed/timing
4 answers Last reply Best Answer
More about post fans cpu gpu spin display
  1. Did you plug the PCI-e power lead into the GPU and plug in the 4 pint ATX power lead onto the motherboard? If yes to both then remove the GPU and boot with the on board graphics. Let us know if that works.
  2. Yes, i have plugged the PCIe power into the GPU and the 4 pin ATX, i also tried the Onboard, through the VGA and the DVI, but no go =(
  3. Also, the mobo chipset heatsink does get warm after its been on a sec, i dont know if that helps or anything but there is that
  4. Best answer
    When you power on, are you getting eight beeps? I purchased the same Mobo for my kids for Christmas, and upon getting it all together today, I'm getting eight beeps, which according to the manual, means Display memory error (system video adapter). I didn't purchase a a separate pci-e graphics card, so I'm just using the on-board gpu. I'm thinking I'm going to have to RMA the mobo. On Newegg's site, someone else posted just a week or two ago that they've done two RMAs for this model Biostar, and none of them have had functioning video.
Ask a new question

Read More

CPUs Motherboards Biostar Displays