Sign in with
Sign up | Sign in
Your question
Solved

do I need to update bios before pc will post

Last response: in Components
Share
January 5, 2014 3:58:41 AM

So.. im building a gaming rig and it wont post. It lights up fans spin etc. Ive tested ALL the hardware in a similar build except the mobo (it lights up and gives beeping error codes when I removed the ram so im sure its ok). Could it be that I need to update the bios version before it works with the cpu. Im using asus pbh61 - mx r2.0 with intel i5 3470 quad core 3.2 and if so how do I check to current bios version? These are new parts. Thanks

More about : update bios post

January 5, 2014 4:15:15 AM

go to asus site, search for your board model, there will be a link there for supported cpu's, along with the bios version that supports it
m
0
l
January 5, 2014 4:16:22 AM

The CPU is supported. Are you getting 1 long 2 short beeps when starting with only CPU and CPU fan installed?
m
0
l
Related resources
January 5, 2014 4:37:48 AM

Yes. I get the 1 long and 2 short beeps. I believe this is the "no memory inserted" error code.
m
0
l
January 5, 2014 4:41:53 AM

Yes. Now insert single RAM module, connect the monitor to the onboard VGA port, keyboard, mouse, DVD drive and start the board.
m
0
l
January 5, 2014 4:50:25 AM

Thanks for the speedy reply. So im currently running with cpu and fan connected. Also ive installed the ram (I tried both slots and one at a time). For now the gpu and other sata devices are left unplugged. Still, lights up and fans on but no display or beep. (It may be worth mentioning im connected to a tv via hdmi. Its connected via on board graphics like so - vga > vga/hdmi adapter > hdmi. The adapter is in good order.)
m
0
l
January 5, 2014 4:55:50 AM

It wouldn't work (analog to HDMI not working without a converter). The HDMI to HDMI might also not work due to the TV not supporting the low resolution.
For first boot I suggest borrowing a monitor.
m
0
l
January 5, 2014 5:02:13 AM

I have used the converter on another rig. The analog to hdmi works. However its a fair point that perhaps my tv wouldn't support such a low res. I will try a monitor to be sure. However this does not explain the missing beep at post. Perhaps my computer doesnt beep to confirm a successful post but it would be a first in my experience. ..
m
0
l
January 5, 2014 5:03:39 AM

Newer boards won't beep anymore if a successful POST.
m
0
l
January 5, 2014 5:12:15 AM

Ok. I'll try a monitor tonight and if it works you can be my best friend forever! Honestly ive built a fair few and screen res didnt even occur to me.
m
0
l
January 5, 2014 5:27:20 AM

Waiting for the result.
m
0
l
January 5, 2014 8:04:16 AM

No. It didnt work. I've borrowed a monitor and still no display...
m
0
l
January 5, 2014 8:46:34 AM

What connection using for the monitor?
m
0
l
January 5, 2014 9:26:56 AM

It should work. You didn't use the Flashback, did you?
Try clearing the CMOS (unplug the power cord and remove the CMOS battery for few minutes) and try again without a graphics card (using the onboard).
m
0
l
January 5, 2014 9:48:29 AM

No and I cleared the cmos. Im using the on board graphics too - ive left the gpu out because it would need drivers installed first anyway.
m
0
l
January 5, 2014 9:54:30 AM

No, it wouldn't. For POST-ing the card does not need drivers. They are part of the operating system.
Try installing the graphics card and see if any change.
m
0
l
January 5, 2014 10:07:50 AM

Ok. The card went in and lit up. But... damn. no difference. I kinda expected this because the on board didn't work to start with... Anyway im gonna go with my hunch that its a compatibility issue with the mobo *bios* and the cpu. Perhaps because my processor is ivybridge and the mobo chipset is h61?
m
0
l
January 5, 2014 10:11:49 AM

Here's the CPU Support list:
http://www.asus.com/Motherboards/P8H61MX_R20/#support
The CPU is supported starting with the very first version (0401). You can check the board's version on a thin bar code sticker on the motherboard (the last 4 digits on that sticker).
I suspect a VGA cable issue.
m
0
l
January 5, 2014 10:59:41 AM

0803. Guess you're right... but the vga cable works with my other pc.
m
0
l
January 5, 2014 11:03:09 AM

Try reseating the CPU and checking the socket for bent pins.
m
0
l
January 5, 2014 12:34:45 PM

Hmm they seem to be ok. Im stumped.
m
0
l
January 5, 2014 12:41:04 PM

Does the monitor work? I still think that the system is OK. Try testing it in a local shop, if possible.
m
0
l
January 6, 2014 5:46:28 AM

Ok so I dropped it into the shop this morning. The guy took the ram out and from the beeps he ruled out cpu and mobo. Apparently its either psu or faulty ram. Possibly a dodgy vga output. Well I swapped out the psu already to a known working model and it didnt work. As for ram - I thought Id get 3 error beeps if it was faulty/incompatible. .?
m
0
l
January 6, 2014 7:06:47 AM

We're back to step 1. What RAMs using? You have tested with single RAM module, have you?
At the shop they should have tested different components and determine the culprit. We already knew that the board did beep, didn't we?.
m
0
l
January 6, 2014 7:26:32 AM

They still have it. Yeh I tried both sticks then one then the other and in alternative ports. Am using 2x4gb crucial vengeance. (1600mhz CAS9) and yeh I received error beeps when I removed them both.
m
0
l
January 6, 2014 7:28:48 AM

Then it's OK. Please post back after solving it, cause I'm curious what was wrong.
m
0
l

Best solution

January 6, 2014 11:50:57 AM

Both ram not compatible - its on the compatible list but I guess not. The guy at the shop changed both to 1333mhz and it booted. Oddly the old ones work just fine on his other computers. Thanks for your help buddy! Now off the maplins to complain about the ram that came *bundled!* with the mobo & cpu.
Share
January 6, 2014 11:53:36 AM

You're welcome and thank you for the follow up.
m
0
l
!