Sign in with
Sign up | Sign in
Your question
Solved

mATX capable of OS installed on SSD and raid 1 on 2 HDD

Last response: in Motherboards
Share
January 7, 2014 12:27:57 PM

Is there a Intel LGA 1150 mATX Board that I can install Win7 OS on a SSD and have 2 other HDD's set up in RAID 1?

The ASRock H87M mATX board I'm currently trying to set up will only let me set all SATA ports to RAID or AHCI or IDE. I installed the OS on SSD with AHCI. When I go into BIOS to create a RAID for the other 2 HDD it won't boot because I changed the SATA controller to RAID.

Thanks!
a c 324 V Motherboard
January 7, 2014 2:31:22 PM

On the ASRock H87M you can use RAID and one SSD and install the Intel Rapid Storage Technology driver and utility ver:12.8.0.1016. Install the driver at the beginning of the Windows 7 installation and the Utility after Windows 7 is installed. Then connect your RAID drives and use Utility to set up your RAID. What makes you think a different motherboard will do it for you?
m
0
l
January 7, 2014 5:42:26 PM

I have tried about everything to get this to work, even the Intel Rapid Storage Technology although ver:12.6.0.1033 as you suggested . Maybe I'm not jumping through the hoops in order.

I've been digging and it seems I may need a MB with two chipsets such as the GA-Z87X-UD3H.

Chipset:
6 x SATA 6Gb/s connectors (SATA3 0~5) supporting up to 6 SATA 6Gb/s devices
Support for RAID 0, RAID 1, RAID 5, and RAID 10

MarvellĀ® 88SE9172 chip:
2 x SATA 6Gb/s connectors (GSATA3 6/7) or 2 eSATA 6Gb/s connectors on the back panel, supporting up to 2 SATA 6Gb/s devices
* Use either the GSATA3 6, 7 connectors or the eSATA connectors at a time.
Support for RAID 0 and RAID 1

I could use the Marvell Chipset for the RAID setup.


Right now I have the OS installed on the SSD. When I go into the BIOS and use the Intel Rapid Storage Technology driver "Which is installed" and change the SATA Mode from AHCI to RAID (so that I can set up the 2 HDD's in RAID 1) it changes the SATA Mode for all the SATA Ports (including the one the SSD with the OS is on).

If i go to the Boot Tab - Under Boot Option #1 the SSD is listed as RAID not AHCI and will no longer boot. Exit Bios and I can get into the RAID Configuration tool and set up the 2 HDD's in RAID but if the computer does not boot It's useless. I have to go back into the BIOS and change the SATA Mode back to AHCI and select the SSD in the Boot Option #1 to get it to boot. Now I have no RAID configuration and the drives not longer show up in Windows. I have to goto Disk Manager to get them back.
m
0
l

Best solution

January 7, 2014 8:21:24 PM

Tried one more thing before throwing inthe towel.

Success!
1) Installed Win7 OS on SSD.
2) Formatted the 2 HDD's.
3) Booted into BIOS > Advanced Tab > Storage Configuration > SATA Mode Selection Select RAID
4) Save Changes and Close > Reboot > CNTL +i to select RAID Configuration > Configure RAID 1 for HDD's
5) Save Changes and Close > Reboot onto Bios > Advanced Tab > Storage Configuration > SATA Mode Selection Select AHCI
6) Reboot to Windows, only SSD drive is visible in widows.
7) Go to Disk Manager and a ONE 1.3TB unallocated HDD was showing. Right Click >New Simple Volume > Formatted
8) Boom New Volume (D) shows in Windows
Profit!

Before after step 4 Windows wouldn't boot back into windows if I didn't set the SATA Mode Selection back to AHCI.
Also Step 7 would should TWO 1.3TB unallocated HDD's if I deleted the array before Changing SATA Mode Selection to AHCI in the BIOS.
Now when restart the computer I do not get a chance to CNTR +i for the RAID Configuration anymore (I did on my old set up).

How do I know this worked?

The Properties for the new volume (D) Disk Manager > Right Click > Properties is: Intel Raid 1 Volume SCSI Disk Properties

I'm still 20% uncertain.

Put two word documents in Volume (D) powered down the computer, disconnected power and one SATA cable from one of the HDD's in the RAID. Powered back on computer and the word documents are in Volume (D)
Powered down again same process with the other drive and the word documents are there.

So it is writing to both Disks.

I'm still 10% uncertain............

So what was the big hang up for me here. Seem I thought I had to leave the SATA Mode Selection in RAID after setting up the RAID. Guess it's just used for creating the RAID.

Thanks for the help!
Share
!