Sign in with
Sign up | Sign in
Your question

Artifacts with ASUS ROG 7970 Matrix Platinum in most games, help!

Last response: in Graphics & Displays
Share
January 9, 2014 7:09:26 AM

I bought the ASUS ROG 7970 around 2 months ago and decided to OC it with ASUS' own GPU Tweak utility. By default the engine clock is 1100MHz. If I go even 50MHz above that I begin to see artifacts in games. In ARMA II the trees are sparkling like Christmas trees with occasional white flashes. In Assassin's Creed IV these small green squares flash onto the screen sometimes. On default 1100MHz it's fine. Also something to note; despite having changed the OC Profile on GPU Tweak back to 1100, every time I start a game it goes back to 1170 I have to alt+tab and change it back to default which is very confusing.

So my question is: Could this be a fault with the software or is it definitely a GPU issue? If I uninstall ASUS GPU Tweak and try MSI Afterburner would I see the same artifacts?

ASRock Z77 Pro Fatal1ty
i5-3570k
8GB G.Skill Ripjaws 2133MHz
Windows 7 Pro x64
a c 651 4 Gaming
a c 929 Ĉ ASUS
a c 205 U Graphics card
January 9, 2014 8:51:23 AM

Give it a try, might be the individual GPU has a problem OCed that high, or may be something with the software - do you have the latest version of it - the latest BIOS and mobo drivers?
m
0
l
January 12, 2014 3:24:10 AM

Tradesman1 said:
Give it a try, might be the individual GPU has a problem OCed that high, or may be something with the software - do you have the latest version of it - the latest BIOS and mobo drivers?


All the latest drivers, yes. I will post after results of using different software or attempting to update ASUS GPU Tweak. I just didn't think that was a possibility.
m
0
l
!