Artifacts with ASUS ROG 7970 Matrix Platinum in most games, help!

I bought the ASUS ROG 7970 around 2 months ago and decided to OC it with ASUS' own GPU Tweak utility. By default the engine clock is 1100MHz. If I go even 50MHz above that I begin to see artifacts in games. In ARMA II the trees are sparkling like Christmas trees with occasional white flashes. In Assassin's Creed IV these small green squares flash onto the screen sometimes. On default 1100MHz it's fine. Also something to note; despite having changed the OC Profile on GPU Tweak back to 1100, every time I start a game it goes back to 1170 I have to alt+tab and change it back to default which is very confusing.

So my question is: Could this be a fault with the software or is it definitely a GPU issue? If I uninstall ASUS GPU Tweak and try MSI Afterburner would I see the same artifacts?

ASRock Z77 Pro Fatal1ty
i5-3570k
8GB G.Skill Ripjaws 2133MHz
Windows 7 Pro x64
2 answers Last reply
More about artifacts asus rog 7970 matrix platinum games
  1. Give it a try, might be the individual GPU has a problem OCed that high, or may be something with the software - do you have the latest version of it - the latest BIOS and mobo drivers?
  2. Tradesman1 said:
    Give it a try, might be the individual GPU has a problem OCed that high, or may be something with the software - do you have the latest version of it - the latest BIOS and mobo drivers?


    All the latest drivers, yes. I will post after results of using different software or attempting to update ASUS GPU Tweak. I just didn't think that was a possibility.
Ask a new question

Read More

Platinum Gaming help artifacts rog GPUs Games Graphics Asus Radeon Graphics Cards 7970 Matrix