Sign in with
Sign up | Sign in
Your question

Need help with Gigabyte Radeon HD 5750 Silent Cell 1GB GDDR5

Tags:
  • Radeon
  • Gigabyte
  • Graphics
Last response: in Graphics & Displays
Share
January 10, 2014 8:36:03 AM

Okay so i couldnt get the card runing,and i asked around here and found out i needed to connect a molex to 6 pin cable ,and put the 6 pin in the card. I had only one molex free,so i pulled another one from the cd drive wich i am not using anyway.So i pulled those those two into the 6 pin adapter,and put 6 pin in the slot on the card . I start up the pc ,and for some time i hear some kind of clicking noise coming from pc,and then after a while i get image on the screen and pc starts up.When i enter windows i cant see card in devices,pc says its using some vga thing or something like that. I turned off my pc, and the card was reaaaly hot ,i put it out for cooling now. What am i doing wrong,how can i get it to work. My PSU is some cheap 500 w one . Should i try using only one molex cable to 6 pin ?

More about : gigabyte radeon 5750 silent cell 1gb gddr5

January 10, 2014 9:35:28 AM

No, you MUST use two molex connectors. Also, you have to install the drivers before the PC will see the card otherwise it's using its generic VGA driver. Yes, the HD 5750 will run hot, it is after all, 3 generations old. It's designed to be hot though so don't worry. My twin HD 4870s got so hot they were a serious burn hazard if I opened my case during gaming. Put the card back in, install the drivers and all should be well.
m
0
l
January 10, 2014 9:59:16 AM

What about the clicking sound and the image coming some time after pc is turned on?
m
0
l
!