Sign in with
Sign up | Sign in
Your question
Solved

Intel Core2Duo Won't boot after taking out drive and putting in another PC

Last response: in Motherboards
Share
January 12, 2014 3:11:43 PM

I wanted to see if I could boot my SSD (OCZ Agility 3) in my laptop since I have virtualization enabled. However, it bluescreened and did not. I took the drive back to the computer it was originally in, and now it won't boot in that. I get an error about selecting a proper boot device.

Obviously I did something to the MBR. What is my best method to restore the MBR so I can get this thing back on track?
Thanks in advance.
a c 102 V Motherboard
a b å Intel
January 12, 2014 3:34:58 PM

Nope, the drivers are probably too dissimilar to boot the laptop, virtualization is not part of the problem.

You can fix the MBR with a startup repair using an installer disk or system repair disc, which you would have had to already have made on the machine in question.
m
0
l
January 12, 2014 3:39:18 PM

There's an article on how to repair boot (if you scroll down, you can read about using the repair from a win DVD or recovery disk). Be careful about using commannds on a MBR on a laptop as it may overwrite the manufacturer's MBR and impair manufacture features (such as accessing recovery software from the bios screen).
http://www.tomshardware.com/news/win7-windows-7-mbr,100...
m
0
l
Related resources
January 12, 2014 3:41:27 PM

Thanks, I'm going to try booting off the 7-install disc and try running bootrec.exe /fixmbr
If unsuccessful, I'll be back :) 
m
0
l

Best solution

a c 102 V Motherboard
a b å Intel
January 12, 2014 3:47:07 PM

You shouldn't even need to run fixmbr, if you just boot with the installer disk in and do a startup repair it will fix the issue.
Share
January 12, 2014 4:45:12 PM

I tried running that, but when it went to the second page after choosing startup repair, there was no OS listed, so then I chose command prompt and tried to type out bootrec.exe /fixmbr but it doesn't even recognize that command.

Why would it not recognize the OS installation on the drive, or do I need to load drivers to get it to recognize the SSD?
m
0
l
a c 102 V Motherboard
a b å Intel
January 12, 2014 4:52:26 PM

No drivers are needed, but I would check the bios settings to insure that it is the primary boot device. Attach the drive to another computer if possible and see if anything will open. If a startup repair won't work, you may need to do a repair installation like THIS.
m
0
l
January 12, 2014 6:10:08 PM

OK, well the BIOS didn't recognize it after that reboot, but then shifting some cables and ensuring tight connections, it was back up and the Windows disc was able to repair it. Back in Windows....crisis averted.
Thanks.
m
0
l
!