Motherboard is NOT dead, only works sometimes

I have a pretty strange problem with my ASUS P5GC-MX/1333, and what the problem is, is that the motherboard is NOT dead, but it will refuse to start up sometimes. It does get the "no ram beep" when i plug ram out, and sometimes i can get it working and booting into the OS. However, if i disconnect a HDD for example it will refuse to start up. I recently got it working by removing and reseating a random jumper, and after that it was still dead. The PSU is good, the RAM is good as well, everything's fine but i cannot figure out why this is. Any help? Yes, i tried clearing the CMOS and battery thing too many times already
2 answers Last reply
More about motherboard dead works
  1. How do you know the PSU is good? Try swapping in a known working PSU.
  2. Well I suppose it is, because sometimes the computer starts up, but i think i found the solution: The problem was that the board is a bit old and the capacitors as well, and it may have accumulated static electricity which prevented it from booting. The solution was unplugging all frmo the motherboard, including the jumper for the CMOS. The next day it worked, and right now it's down in my basement running as a server. This is not the first time this problem occures, but it's the first time i think i found out how to solve it.

    Update: Upgraded the PSU with a confirmed good one, will check if problems still occur.
Ask a new question

Read More

RAM Motherboards