Sign in with
Sign up | Sign in
Your question

Trashed RAID 1+0 array?

Last response: in Storage
Share
January 16, 2014 9:09:01 AM

I'm running an HP ML310 server for video. It has 2 RAID arrays running off the HP P600 controller. One is a 3Tb RAID 1+0 (i.e., 6 1Tb drives configured as a mirrored 3Tb drive). When rebooting (such as for an upgrade) the controller bios often (but not always) gives a warning that one of the drives should be replaced but it then proceeds to rebuild the array. it's clear that drive hasn't completely failed cause the rebuild brings it back and then the array works fine.

Anyway, the situation made me nervous so I finally got a replacement drive. My understanding (??!!??) was that if I swapped the new drive and rebooted, that the controller would then see the new drive and give me the option rebuild. I tried that, but controller diagnostics told me that the whole array had failed, it didn't try to rebuild. I swapped the original drive back in with the same result. Machine boots fine (the OS is on the other array), but the P600 diagnostics tells me that the whole array is FAILED. I didn't try to initialize the new drive.

Am I hosed? Any possible way to get my array back up? Any help greatly appreciated. I'm an idiot in over my head. :ouch: 

More about : trashed raid array

a b G Storage
January 16, 2014 9:20:16 AM

Can you not hot swap those drives while it's running?

Try putting the old drive in and see if it will boot.

If it can't boot, I'd say you waiting to long or another disk may have errors as well. If you wait to long, it's possible that bad data can spread from the bad drive and duplicate onto the other drives. When you rebuild, you transfer that bad data to the new drive as well.

You might want to pick up a single 6 TB NAS just for saving a daily compress backup.
m
0
l
!