Sign-in / Sign-up
Your question
Solved

A quest for internet access ( unidentified network and error 651 )

Tags:
  • Internet Access
  • Network Card
  • Networking
Last response: in Networking
January 17, 2014 6:04:33 AM

I'm stuck with one of the most harsh problems i had to deal with, regarding fixing my computer.Im trying to solve it for days ( have
searched a lot on the web ) and no results so far.
The problem is about network and internet access.

I have a broadband ADSL connection and until this problem showed up, my computer had regular internet access on Windows 7, with my onboard network card connected to
the ADSL modem ( TP-LINK TD-8816 ), no routers. Suddenly ( after coming from stand by ), my pc had no internet access and when i checked the Local Area Connection, the status
showed as Network unidentified, which doesnt even let me access the configuration page of the modem by its ip address.I tried to
start my ADSL connection ( modem was on bridge mode ) and Windows 7 points me error 651.
I tried to diagnose the problem with Windows and it says my Local Area Connection
doesnt have a valid ip configuration.

Quickly, i pluged my ADSL modem with the same RJ-45 cable on my Dell netbook to see if the problem was my computer or with the modem.
Then i saw that my Dell's network card was behaving regularly with my modem and i could both access the modem configuration page
as well as have internet access.

So, imediately i discarded my broadband provider,my modem and the cable as the fault. I was sure the problem was on my PC ( either hardware or software ).
I started with software-, i tried a lot of things like updating the driver, searching services like Bonjour or ##ID_String type ( it didn't have any ), removing IPV6,
installing reliable multicast protocol, assigning the modem gateway ip manually.
None of these worked.
Then i decided to format my HD and re-install Windows 7 from scratch.
After that, oddly, the problem still persisted. That made me go to the hardware and blame solely my onboard network card ....
Then i went to buy a new network card. The network card i chose was the Encore ENLGA-1320 , which oddly had the same Realtek PCI GBE controller, seeming exactly like i had bought
my old onboard network card.
So, i installed it and i didnt even have to install any driver because the Encore's driver was the same as my onboard's network card driver.
After connecting the modem to the new network card, the problem still persists : Network unidentified, and no internet access with error 651.


But then i made some test. I pluged my D-LINK Router on the new network adapter and it recognized it, i was able to access its configuration page.

Not on the old network adapter ( onboard one ), so it suggests my old network adapter was faulty.

Checking the ipconfig /all on the ADSL Modem i get this : , according to the unidentified network ( after trying to identify for some seconds ).






Then, a second later, changing one end of the RJ-45 cable from the ADSL-modem to the D-Link router, my network adapter quickly identifies
a network and i get a perfectly fine ipconfig /all :







To sum up the confusion :
On one side i get the message that the ADSL modem is okay because even tho it doesnt work on my new network adapter from my Desktop PC, it works perfectly fine when pluged to my Dell netbook.
But on the other side, i get that my pc software-hardware ( windows and my new network card ) are okay and maybe the problem
is still with the ADSL modem because even tho my new network adapter doesnt recognize the ADSL modem, it recognizes perfectly well my D-Link router ( not giving unidentified network message ).

Any clues ? Should i buy a new ADSL modem even tho it works on my dell netbook ?



Thanks a lot,it really means a lot for me to get this figured out.





More about : quest internet access unidentified network error 651

January 17, 2014 6:24:46 AM

What does ipconfig /all give you? Can you ping your own IP? Also, I would disable the onboard NIC and reinstall/update the driver, even though you say it's the same one.
m
0
l
January 17, 2014 7:02:26 AM

Hello, evims. Thanks for trying to help. I can ping my own ip ( doing ping 127.0.0.1 i get less than 1ms response and 0 packets lost ). I also tried to reinstall the driver with the old network adapter disabled, but it didnt work.
As for the ipconfig /all , i updated the original post with links to images that show my ipconfig /all in both sittuations.

Thansk a lot for the help, seriously.
m
0
l
Related resources
January 17, 2014 8:20:16 AM

You say in the OP that you statically set the gateway, did you also statically set the IP? The 169 IP is only assigned when there is no connection to a DHCP server, typically a router. Statically set this information on your NIC:

IP: 192.168.0.X (X can be anything up to .254, but don't assign it something that is already in use.)
Subnet Mask: 255.255.255.0
Default Gateway: 192.168.0.1

Also, set your DNS servers to:

8.8.8.8 and 8.8.4.4
m
0
l
January 17, 2014 11:52:47 AM

I statically set the ip adress, default gateway and DNS servers as you mentioned but the problem still persists :( .
Thanks a lot in advance
m
0
l