Solved

Dell XPS 8300 not detecting PCIe USB 3.0 Card

I have a Dell XPS 8300 that I recently tried to upgrade by adding a 2-port USB 3.0 PCIe card. There were two free PCIe slots next to the graphics card, and a free connector I could use for power, so I ordered a PCI card and a front panel & installed it according to instructions. However, the computer doesn't seem to recognize that a new USB controller has been installed at all - no yellow exclamation marks, Scan Hardware doesn't produce anything new. The only thing that *does* happen is that the PC automatically installs a "PCI Bridge" driver for intel 6 series/c200 family pci express root port 2. I highlight below in the Device Manager the exact component:



Meanwhile, the USB section doesn't show any USB 3.0 ports or controllers:



Things I have Tried
- Used two different power cables. Measured voltage on both. Should be both working.
- Tried the card in two different PCI slots. Same results.
- Upgraded BIOS from A05 to A06. Did not see any BIOS options to enable or disable PCI slots.

EDIT: Once I disconnected the USB 3.0 front panel from the USB card, the system properly detected the PCIe USB 3.0 card and the back ports worked. However, the minute I connected the 20pin connector between the two, the system once again repeated the behaviour.

If anyone can offer any insight as to why this is happening, that would be greatly appreciated.
6 answers Last reply Best Answer
More about dell xps 8300 detecting pcie usb card
  1. Have you tried the ports on the card? That the port two is now has a driver means it is detecting the card which may simply be broken. Did it com with drivers?
  2. I bought it off ebay, and the only drivers it came with were a bunch of USB 2.0 drivers on a hand-made CD ROM. I ended up reading the chipset number off the card itself and downloaded a Renesas/NEC driver for it.

    Just plugged in a working flash drive into all the ports, and none of them recognized the new drive being plugged in.
  3. Well maybe it is simply broken and you should try return.
  4. Update to the problem:

    I disconnected the USB 3.0 front panels, and now my computer will recognize the USB card and install the drivers properly. However, the minute I connect the 20-pin connector from the USB 3.0 front panel to the card and reboot, the system stops recognizing the card.

    Anyone have any idea why this could be happening? I'm happy to at least get the two back ports working, but it'd be more convenient if the front ports worked too.
  5. Best answer
    Most likely something wrong with the connector on the card. Slimmer chance something is wrong on the case.
  6. Ordered a card from Newegg, and this one works. Must have been an unreliable connection on the old one. Thanks for your help!
Ask a new question

Read More

USB3 dell xps 8300 Dell Studio Xps usb card Components PCI Express