Sign in with
Sign up | Sign in
Your question

What is wrong with my rig? I cant find solution-bad performance HELP PLS

Tags:
Last response: in CPUs
Share
January 21, 2014 3:46:44 AM

Hello everyone,

I have a problem that makes me mad. On my rig: Cpu intel u7 920 currently OC to 3,69 GHz, MSI GTX 670 PE 2GB, PSU OCZ extreme 700w and 3x2 gb Ram DDR3 1333MHz I have poor FPS in many games(especially MMOs), with low cpu and gpu usage. For example in Wow at 25man raids it dips to 20 fps on ultra and in towns i have 30-55 fps with low cpu and gpu usage. Same in Tera, Rift, AC4 Black flag, Neverwinter online, etc. Firstly i thought it can be CPU bottleneck, so i OC my cpu to 3,7 Ghz and gained maybe 5 fps but still low cpu and gpu usage. Mostly i get 20´s to 30´s in any mmo populated area, and in FFXIV:ARR even teens in group events and in GW2 in WvWvW I have about 10 fps :/  :XD. Changing settings help only a little (5-10fps) and sometimes doesn´t help at all...

Im running Windows 8.1 Pro x64


In Unigine Heaven and Unigine Valley i got 99% gpu usage and in some games too (crysis 3 etc).


I love MMO´s but i can´t enjoy them. This problem lasts nearly 1,5 year and i never found any solution. BTW i tried playing with and w/o HT, and C-states on and off. No change exept BF4 runs better without HT.

Can it be my cpu? Even at 3.7ghz and in all mmos? I doubt that.
I would be very gratefull if someone can help me solve this out.

Have a nice day :-)
a b à CPUs
January 21, 2014 3:52:55 AM

Possible reasons:
1. I think your cpu is overheating. Clean the heatsink and CPU with 99% isopropanol using a lint free cloth and use brand new thermal paste.
2. CPU is bottlenecking the card.
3. GPU fan is full of dust and throttling.
4. GPU is dying.
5. HDD is slow and fragmented.
6. HDD is dying.
7. Update GPU driver.
a b à CPUs
January 21, 2014 3:59:48 AM

Nothing to do with your rig.
That how wow have utilized it. You sets down the fps when are lot of people are near, so you wont experience it lagging.
it's smoother 20 frames.

Related resources
January 21, 2014 5:02:25 AM

Hi rounakr94,

1) My temperatures are pretty high now, but i had this problem even on lower clocks with 65 C degrees at full load

2) I thought that so, but @ 3,7 in all mmos? Thats strange, isnt it? CPU is never above 80 % usage in this kind of games, but gpu is @ cca 40-70%

3+4)GPU is completely fine, it only 1 year old and idle temps are @ 35 degrees and full loaded temps never exceed 65 degrees

5+6)I have clean install of win 8.1 Pro x64 so...but yeah its 5yrs old HDD

7) I always keep drivers up to date :-)

Hello vmN:
its not only wow problem, it affect all mmos, for example: Tera max settings-40-80 fps in not much populated zones, 15-30 in cities and populated zones / Rift: 50-120 fps on max without shadows in non populated zones, 20-30´s in cities, +-40 in pvp warzones / FFXIV:ARR : in v2 benchmark i had average fps of 92 all maxed out, ingame i have +-50-90 in non populated zones and 20-30s at cities and even 15 fps in large events, while my cpu and gpu isnt used more than a half on both and Neverwinter online is dissaster, in city - +-20fps and in other zones +-40-50fps, fps raise if i turn of the UI. same in TERA. I have no problems with games like Crysis 3 etc, maybe now in AC4 Black flag and BF4, but its poorly optimized so...Im lost at this point, I would be veeeery grateful for solution! An yes, i tried switch on prefer max performance in nvidia control panel.

There are some screenshots of HW info etc:

CPU-z


HWinfo64 + idle temps


HWinfo64 + intel burn temps (max torture test)


CPU and GPU usage while playing TERA:


TY all

January 21, 2014 5:10:11 AM

Daraeon said:
Hi rounakr94,

1) My temperatures are pretty high now, but i had this problem even on lower clocks with 65 C degrees at full load

2) I thought that so, but @ 3,7 in all mmos? Thats strange, isnt it? CPU is never above 80 % usage in this kind of games, but gpu is @ cca 40-70%

3+4)GPU is completely fine, it only 1 year old and idle temps are @ 35 degrees and full loaded temps never exceed 65 degrees

5+6)I have clean install of win 8.1 Pro x64 so...but yeah its 5yrs old HDD

7) I always keep drivers up to date :-)

Hello vmN:
its not only wow problem, it affect all mmos, for example: Tera max settings-40-80 fps in not much populated zones, 15-30 in cities and populated zones / Rift: 50-120 fps on max without shadows in non populated zones, 20-30´s in cities, +-40 in pvp warzones / FFXIV:ARR : in v2 benchmark i had average fps of 92 all maxed out, ingame i have +-50-90 in non populated zones and 20-30s at cities and even 15 fps in large events, while my cpu and gpu isnt used more than a half on both and Neverwinter online is dissaster, in city - +-20fps and in other zones +-40-50fps, fps raise if i turn of the UI. same in TERA. I have no problems with games like Crysis 3 etc, maybe now in AC4 Black flag and BF4, but its poorly optimized so...Im lost at this point, I would be veeeery grateful for solution!

TY all



Did you overclock on a stock cooler? if so BAD BAD BAD! I have a LGA 1366 Scythe Mugen II you can have if thats the case.
a c 374 à CPUs
January 21, 2014 5:22:02 AM

An i7 920 has 4 cores 8 threads. The reason you're not seeing above a certain % of usage is because many games are not coded to handle that many cores/threads - many only use up to 2, some others up to 4, and a few up to 8. The i7 920 is starting to show its age since its over 5 years old and the single core performance is lacking, similar to an AMD FX in some respects. I believe you'll require a CPU and mobo upgrade, at least from what you've said. I believe WoW only uses up to 2 cores/threads (correct me if im wrong) resulting in the lower FPS you're experiencing.

What I'd suggest you do is monitor the CPU performance graph in Task Manager, so that you see the usage of each individual core not just the CPU as a whole. If you're maxing out on a core (100%) it's possible that it's causing the low FPS. In addition you may have some cores/threads parked, you could try using this tool: http://bitsum.com/about_cpu_core_parking.php

It's probably worth changing to a 7200rpm HDD and probably an SSD too, its possible its causing a bottleneck in some games.
January 21, 2014 5:24:33 AM

Nope, i OC on Arctic freezer 13 heatsink...
January 21, 2014 5:39:31 AM

Daraeon said:
Nope, i OC on Arctic freezer 13 heatsink...


Then I would listen to JOOK-D
January 21, 2014 5:55:09 AM

There is Tera usage on all cores, it is high, but its not 100% and gpu usage is on 40%....
a c 374 à CPUs
January 21, 2014 6:00:25 AM

Make sure you have Vsync, AA and AF turned off in all games.
What kind of FPS are you getting in tera?
Also close any background programs you have open.
January 21, 2014 6:14:09 AM

I got about 20s in town and 40 outside the town, i always have vsync off and turning on/off aa and af makes max 10 fps in mmogames, while gpu isnt still used more than 40+-%

Now Im trying copy TERA on different HDD which I plugged now and im curious if this help somehow...
January 21, 2014 10:33:39 AM

Any1?
February 6, 2014 10:38:04 AM

Bump
!