BF4 NVIDIA Geforce 9600M GT does not support dx 10 error message

Guys, I know its not the best gpu for the game , but still should work with this ,It should support dx 10 *checked on net* . So guys what should I do to get rid of the problem somehow...?

Error message:
---->Your computer does not meet the minimum requirements for playing this game.
"NVIDIA GeForce 9600M GT " GPU does not support DirectX 10.0 which is required.<-----

Processor-Intel(R) Core(TM)2 Duo CPU P8400 @ 2.26GHz 2.27GHz
RAM-4.00GB
System type- 32-bit operation system
Windows Vista Home Premium
GPU- NVIDIA Geforce 9600M GT

I know its possible I saw a video and the man said he's running the game with the same GPu.
2 answers Last reply
More about bf4 nvidia geforce 9600m support error message
  1. Probably a silly question - Have you updated your DirectX lately?
  2. Well Yea, I used the directx exe , in the Battlefiel 4/ _installer/directx/redist/dxsetup.exe , and it automatically install and update if necessary .... maybe it not working correctly .. hm dont know
Ask a new question

Read More

Support Graphics Error Message Games Geforce Nvidia GPUs