Sign in with
Sign up | Sign in
Your question
Solved

USB 2.0 drive NOT detected in Explorer, Comp Management/Disk management or Device Manager

Last response: in Storage
Share
January 22, 2014 11:46:21 AM

I have a Sony Vaio 64 bit running Windows Home Premium. I have been using my Kingston 2.0 8bg USB thumb drive to backup work. Yesterday, the window continued to popup to automatically open the thumb drives contents and today it doesn't work. I have done several troubleshooting steps, where I have checked the devices and disk management. The device does not show up in either or these, nor explorer. It's not a drive assignment issue. I tried in another Windows PC, no recognition. Additional info: the plastic enclosure broke off the thumb drive 2 days ago. I snapped it back together and taped it snug, which was working. I know, I should have backed up. Anything I can do to recover my data, geek squad, or preferably anything I can do to get the drive to temporarily register again to save the data or is it just toast? Any help is greatly appreciated!
a b G Storage
January 22, 2014 12:03:33 PM

sorry to say, but my guess is, it is toast.
m
0
l
a b G Storage
January 22, 2014 12:13:29 PM

It's toast :( 

There are companies that may be able to recover some of your data, but their services cost hundreds or thousands of dollars...
m
0
l
Related resources
a b G Storage
January 22, 2014 12:17:38 PM

here is a simple solution that may help. (works best if there is an LED "operating" indicator)
take the enclosure off altogether, plug the "naked" flash drive into the usb port, carefully move the circuit board up /down a little at a time until the light flash, once you find a position that works, quickly move/copy the files to the computer, (some very cheap people will still use the flash drive after this, but i recommend getting a new one because it will break completely pretty soon)
m
0
l
a b G Storage
January 22, 2014 12:20:19 PM

aevm said:
It's toast :( 

There are companies that may be able to recover some of your data, but their services cost hundreds or thousands of dollars...


very helpful... :( 
m
0
l
January 22, 2014 12:39:15 PM

Okay, not the answers I was hoping for, but expected that to be the case. In my last bout of desperation - I will try gently moving the circuit board up and down, since the I already removed the cover to use an air sprayer to clean off any possible dust or lent that may have been causing an issue. The only odd thing is that I do now get a message as follows after 'cleaning' the drive: "One of the usb devices attached to this computer has malfunctioned and windows does not recognize it", which I did not get previously. Still no sign in Expl, Device Mgr, or Disk Mgmt. I will report back my final findings. Thank you to all who responded! : (
m
0
l

Best solution

a b G Storage
January 22, 2014 12:44:31 PM

all is not lost: if you get the message, there is a contact between the USB (the aluminum part that fits in the usb connector) and the circuit board.
usually the circuit board is not in the middle of the connector but to one side of it. the side that it is shifted to is the "down" side and you should try to gently move it up to make it work.
it will probably "lean" to one side like this:
Spoiler
and you should move it against that lean
Share
January 22, 2014 2:22:25 PM

Wrathofdragon - You are a genius, I cannot thank you enough! I just finished copying all of my data over and just in time as it stopped working right at that point. I now plan on backing it up properly on multiple drives. For anyone with this problem going forward, the keyword is 'gently' bend.
m
0
l
a b G Storage
January 22, 2014 2:38:46 PM

Glad to help. :) 
m
0
l
!