Sign in with
Sign up | Sign in
Your question

32gb PNY USB flash drive reading as Other Media by Windows 7

Last response: in Storage
Share
January 23, 2014 5:14:51 PM

So I've got a problem with a new PNY 32 GB USB flash drive I bought. So far it's been problem after problem. It started out with shamefully slow write speeds. (under 1 MB/s) Then it kept corrupting data halfway through a file transfer.

So I was in the middle of trying different formats and the power went out long enough for the computer to power down. The USB was in the middle of a format and now it's not readable by Windows. I've tried all the common solutions.

It displays under my computer but it is silhouetted out. I can change the drive letter and drive name. Windows informs me that there is 0MB on the drive. It apparently shows up as some kind of media device now. It can't be formatted either. The error message given is: "there is no disk in drive X: insert a disk and try again"

Under device manager it shows up under Other Devices. Windows also fails to install a default driver for it. So far I haven't been able to fix it. Re-assigning drive letters is no use, unplugging and replugging in other ports/computers gives the same problems. Uninstalling the driver via device manager and rebooting Windows is no good either.

I can only assume something weird has happened and now Windows cant recognize it as a readable storage device or such nonsense. Under Disk Management is shows up as 'No Media'.

Anyone have a possible solution to this or further troubleshooting I could try?

System Specs:
Windows 7 64 bit
i5-3570k
8 gb ram
evga gtx 660


Before anyone suggests I return it that is what I intend to do if I can't fix it.
a c 242 G Storage
January 24, 2014 11:19:34 AM

Windows won't install a device driver unless the related device is detected, so that's normal Windows behaviour as it's not detecting the pen drive.

since the pen drive has never worked properly from day one, go ahead with returning it.
m
0
l
!