Sign in with
Sign up | Sign in
Your question
Solved

AMD Catalyst Control Center no longer showing CPU Overdrive

Last response: in Overclocking
Share
January 26, 2014 12:28:24 PM

Ok so firstly I would like to thank all of you for always giving such wonderful information to all my question I have learned many things from all of you.

So heres the deal, I have just upgraded my system from a Radeon 6750 to a Radeon 7770 2GB GDDR5 and from an AMD FX 6100 BE to a AMD FX 8300 BE, before I did this I turned off all of my overclocking in Catalyst. Hardware is amazing my problem is the software, CPU overdrive is no longer present in the Overclocking menu and AMD Overdrive for the GC is telling even on default settings when I press check custom clocks it fails am I missing some kind of driver here also my MB is an ASUS M5A99X EVO so with the AI Suite II I can overclock with that as well but I do not know how stable or trust worthy it is even though overclocking may not be necessary I would like to see how much power I can get out of the system. and as always thank you in advance.
a b K Overclocking
a b À AMD
a c 77 à CPUs
January 26, 2014 12:32:45 PM

did you have the bios for that cpu upgrade on the motherboard maker ,also did you remove the old amd driver before the instal of the ne gpu that should help .
m
0
l
January 26, 2014 12:49:20 PM

scout_03 said:
did you have the bios for that cpu upgrade on the motherboard maker ,also did you remove the old amd driver before the instal of the ne gpu that should help .

The BIOS has been there since the incial build with the FX 6100 and the 6750 so I have made no attempts to upgrade or change the BIOS (it scares me honestly) and as for the drivers no I did not remove the old Drivers I will check that.
m
0
l
Related resources

Best solution

a b K Overclocking
a b À AMD
a c 77 à CPUs
January 26, 2014 1:14:55 PM

the 6100 use the 813 and the 8300 use 1604 http://www.asus.com/Motherboards/M5A99X_EVO/#support check on the link or user manual on how to do it in windows .
Share
January 26, 2014 1:57:29 PM

scout_03 said:
the 6100 use the 813 and the 8300 use 1604 http://www.asus.com/Motherboards/M5A99X_EVO/#support check on the link or user manual on how to do it in windows .


Ok well I am using right now AI Suite II to check for any necessary update my current version on the BIOS is 0901 which from what you are explaining to me could be the issue I will check and update if needed and return with update if problem has been corrected or not. Thank you for your time.
m
0
l
January 26, 2014 5:24:19 PM

scout_03 said:
the 6100 use the 813 and the 8300 use 1604 http://www.asus.com/Motherboards/M5A99X_EVO/#support check on the link or user manual on how to do it in windows .


Thanks after downloading the ROM and flashing the motherboard I have full over clocking capabilities again though Catalyst is still telling that my GC on default settings is failing the thing I need the most now works so thank you very much.
m
0
l
!