Sign in with
Sign up | Sign in
Your question
Solved

PSU issue in Aurora R1

Tags:
  • psu not working
  • gtx 660 ti
  • 660 ti
  • Components
  • PSU
Last response: in Components
Share
January 29, 2014 9:45:52 AM

First time using this site by asking a question ,but have used it many times so I will do my best to be as detailed as I can.

I have an Alienware Aurora (bought in highschool under a credit plan, regret it every day bc I overpaid so much)

I have an intel i7 920 overclocked to 3.7 ghz, a gtx 660 ti, 9 gigs of ram (1033) and a liquid cooling system from Alienware (Asetek I believe)

I had been under the impression for the longest time that I had a 875 watt PSU, since the system originally shipped with dual 260 GTX in SLI. I recently upgraded to a 660 ti, and am getting barely 20 fps in games, certain graphics are missing, it just seems my GPU isnt getting enough power. So I did some digging in my computer and actually found out I have the 525 watt power supply. The PSU is 80% silver, and is the PSU U597G.

So, my question is: Is that what is causing problems? Would downclocking my CPU help in any way? Or is my only option to upgrade the PSU. If so, could you recommend one that would fit inside of an Alienware Auora R1 case?

More about : psu issue aurora

Best solution

January 29, 2014 10:20:39 AM

Your power supply is plenty for your system.
First thing to try is a clean install of the drivers for the video card.
Download drivers if you do not have the install disk.
Download driver sweeper.
http://www.guru3d.com/content_page/guru3d_driver_sweepe...
Uninstall graphics driver from programs list.
Reboot into safe mode. Do not let windows install a driver for the video card.
Run driver sweeper. And remove all GeForce graphics drivers.
Reboot into normal windows and install new driver.
Share
January 29, 2014 11:55:44 AM

Ok. Did as you said. I ran into one conflict though, after clearing drivers with the DDU utility, an HD Audio driver was installed by windows, and I was unable to stop it. I had previously turned off automatic installation of drivers in devices and printers, so I assume this was unavoidable? Doing a fresh install now, but if the above is going to be a conflict (seemed to be a generic audio driver) I would like to know now haha. Thank you again for your incredibly fast reply.

Update: Everything seemed to install correctly. You were right in that I had old drivers for my GTX 260 on there. After cleanup, I did a stress test on my GPU after installing the drivers (Unigine Heaven), with no overclock. I ran GPU-Z with it, and while idle, Util was the perfcap, which I understand is normal. During testing, VRel and VOp (reliability voltage and operating voltage respectively) were showing up, and later on, Power. Is this a problem? It seemed weird that my card only averaged 24 fps, with a minimum of 15.4, and a maximum of 61.5. Perhaps that is normal though.
m
0
l
Related resources
January 29, 2014 1:16:18 PM

The sound driver is not a problem. it will get replaced with the GeForce driver during the VC driver install.
If you are running the latest version of Heaven, then your score is about right.
Try some of your games now and see if your problem persists or has been resolved.
m
0
l
January 29, 2014 6:38:01 PM

The main problem was during raid last night, where during high action scenes, I was stopping and stuttering down to 15-20 fps and barely maintaining a high of 24 fps during low motion scenes. I have been doing fine with my 660 ti at 30-40 until recently when I overclocked my cpu from 3.4 to 3.7 ghz, only increasing vcore +80. Everything was stable, but I did not think increasing my CPU would cause frame rates to go down.

I am about to raid and will update during and after as to whether the problem has been fixed.

Update: Seems to have fixed the problem, and I am getting a steady huge increase of FPS while in raid as compared to the other day.
m
0
l
!