Sign in with
Sign up | Sign in
Your question

Web server not accessible through internet

Last response: in Networking
Share
January 29, 2014 10:41:25 AM

Hi
I recently switched ISPs from Plusnet to BT. On Plusnet, I had a static IP so I could easily set up A name records for my website which I host on a Windows Server 2012 installation in my bedroom. Now on BT, I've moved to CNAME records and NoIP dynamic IP service. I'm also now using a Wi-Fi extender with ethernet to connect up my server.
Unfortunately, my website does not seem to be accessible. I have set up port forwarding to my server (static IP address, 192.168.1.33) using both BT Home Hub 4's HTTP Server, Web Server(HTTP) and a custom Webserver. I have even tried putting my server in the DMZ however none of this seems to work and my website remains inaccessible, using the domain name (benmckinlay.com), the dynamic DNS address (benmckinlay.no-ip.org) and my external IP address.
Is there something I'm missing here? I'm using BT Home Hub 4, firewall is set to default. Is connecting via the Wi-Fi extender messing things up? Is there some setting either in the router or WIndows Server 2012 (which worked fine previously, though not using dynamic DNS) I need to change? Any other suggestions on what could be causing the problem?
Help would be appreciated.
Thanks
Ben
January 29, 2014 4:19:26 PM

You can try disabling the firewall just to rule out an issue there. The wifi extender could potentially muddle things up, you may want to try connecting direct to your modem to determine if any of your internal equipment is the issue. Another thing to note, many ISP's block traffic on port 80 unless your a "business class" subscriber. Generally speaking if you have a static ip you have a business designation, however not always the case. I would definately check with your ISP to ensure inbound port 80 traffic is available.

I did some brief research on plusnet and apparantly there is a built in broadband firewall on the modem? People had to log in to the plusnet provided device to allow inbound traffic on port 80.
m
0
l
January 30, 2014 9:54:13 AM

I've tried on my laptop connected via wi-fi to the actual router and it is working fine, no issues regarding port forwarding there, so its not an issue with the Home Hub or BT blocking ports. However, when connecting the server to the router via power ethernet plug, port forwarding still isn't working. Any other suggestions for a fix?
m
0
l
January 30, 2014 10:38:51 AM

After further checking, it turns out the problem was that when setting the static IP I also had to set the default gateway and the DNS servers. Although the IP transferred over without a problem, the default gateway and DNS didn't, stopping it from working properly. Anyway, its all fixed now. Thanks for the help
m
0
l
Related resources
!