Sign-in / Sign-up
Your question
Solved

Weird problem on startup.

Tags:
  • Asus
  • BIOS
  • Motherboards
  • Hard Drives
Last response: in Motherboards
January 30, 2014 9:02:04 AM

Hi all,

About 3 months ago i upgraded my pc (new mobo, ram & cpu) and all was fine until Monday morning when i went to boot my pc and got 5 post beeps (2 low 1 high 2 low) and message saying "no OS found, try unplugging any non OS drives" or words to that effect. I rebooted and went to the bios where my main OS drive was not showing up but my others were.

So i tried unpluged my second HDD booted up and all i got after the post beeps & the asus pic screen was a blinking cursor. so i rebooted went back into the bios, still no HDD showing up so i choose don't save and reset, then i got 3 post beeps and it then booted as normal into windows!

Anyway after backing up my important stuff to usb stick i shutdown and tried reconnecting my storage HDD and it booted up fine with no post beeps and straight into windows both drives as normal!? but i've had to do this every morning this week lol.

I've looked up post codes but can't find anything conclusive, some say ram or cpu others say gpu?

i've tried changing the GFX card and this makes no dif
i've tried changing the ram around and single (all combination)

but it still does the same thing every morning lol

when the pc is up and running it works fine in games, 3d studio, Photoshop etc

So i'm not sure what else to try now other than maybe updating the bios.

So any ideas?

PC spec,
Asus B85-Plus haswell motherboard (UEFI BIOS)
Crucial 8GB (2x4gb) DDR3 1866Mhz Ballistix Tactical Memory
Intel Pentium Dual Core G3420 3.20GHz Socket 1150 3MB Cache
Asus 8800GT or EVGA 8800 GTX graphics card (no change with either installed)
WD sata 2 640gb Black HDD (Main OS)
WD sata 2 320gb blue HDD (storage)
Asus sata DVD RW drive
Asus Xonar DG PCI sound card
Coolermaster GX 650w 80plus PSU

OS = Windows 8.1 64bit


More about : weird problem startup

Best solution

a b Ĉ ASUS
a c 124 V Motherboard
January 30, 2014 9:17:06 AM

After all of that, you haven't considered that this may be a problem with your HDD and/or mobo?

Typically, the mobo would kick the bucket before the CPU, and the fact that you can consistently enter UEFI BIOS, suggests that CPU, GPU, RAM and mobo are fine.

Your suspect list is likely the following:

Cables (SATA and/or Power)
PSU
HDD

Start with changing the SATA data cable. If you don't have a spare cable, try changing SATA ports.
Share
January 30, 2014 9:34:44 AM

i've tried different Sata ports with no luck & i've changed the cables around.

on another note would the fact that there sata 2 drives plugged into sata 3 ports with sata 3 cables make any difference?

m
0
l
Related resources
Can't find your answer ? Ask !
a b Ĉ ASUS
a c 124 V Motherboard
January 30, 2014 5:46:20 PM

The cables don't have to specify SATA 3 in order to have the data transfer rate of up to 6Gbps, although this is a completely different matter.

To answer your question, though, no, as the transfer rates are determined by the devices. I.E. SATA 2 device plugged into SATA 3 mobo is limited to a max transfer rate of 4Gbs; and likewise for a SATA 3 device plugged into a SATA 2 mobo.

The problem of the randomly disappearing HDD is likely HDD failure.

A word of caution, if the BIOS updates found on the manufacturer's website do not specifically address your concern, do not patch your BIOS. You may want to contact the mobo tech support to find out if there are any other documented cases similar to yours. If this is a mobo issue, the tech support may have a solution.
m
0
l
January 31, 2014 10:48:35 AM

Thanks for your help on this T_T

This morning i tried a few things and it seems to only post beep when the Main OS HDD is connected. So as you said its mostly HDD failure, although i ran the WD S.M.A.R.T diag tools and it checks out ok.

I also tried the HDD with just the power connected and no data and this also causes the post to beep. But when the main OS HDD is not connected with either power or data there is no post beep, which led me to thinking its a problem with the HDD's power & as i'm running the Intel rapid storage tech which powers the drives up and down depending on its usage i'm thinking this may be the problem so i've now disabled the link power management and will see if this has any effect when i boot it up again tomorrow.
m
0
l
February 2, 2014 3:43:47 AM

So disabling link power management did not solve the problem, although it is still disabled.

Yesterday i tried the HDD in another computer a few times and each time it booted fine straight to windows & i used the cables that where in that PC and not the ones from mine, Anyway i managed to find an older sata cable and im now using that which seems to have fixed the problem :) 

Strange though as the cable i was using works fine with my other HDD?!

i did also changed my dvd drive from using the sata 2 ports to using the sata 3 ports with the other drives.

I kept this updated so hopefully it will help someone else out some time
m
0
l