Sign in with
Sign up | Sign in
Your question
Solved

P2P Disables Internet Browsing - 2 Router 2 Network Cascading Help

Last response: in Networking
Share
February 1, 2014 3:27:46 PM

I recently moved into a new house and got Century Link's 40mbps service. I have two WiFi routers: The Linksys WiFi that covers the whole house is for my parents while the Netgear is for my personal use (PC (wired), Xbox, Tablets, etc).

Anyway here is my setup:
I have a fiber ethernet port in the wall so all I need is a router. The routers are set up cascading.
Ethernet port --> WAN Port Linksys EA4500 (192.168.1.1 DHCP Enabled) Lan Port --> WAN Port Netgear WNR2000 (192.168.2.1 DHCP Enabled)

For the most part this setup is working fine and well but just in case I missed anything or if I can make any changes to maximize performance any and all tips are welcomed.

Now I have this one problem that raises some major concern: As soon as I open any p2p on my PC (hardwire connection to Netgear router), all connections continue except for p2p programs and all web browsers. In hindsight, I can simply not use any P2P programs but I am concerned that this can become a nuisance later on.

How can I prevent this issue from happening or run any tests if at all possible? I'm guessing it's an issue with my ports but I am a total novice to networking... any help would be appreciated.

Thanks in advance

Edit: I forgot to add that with only one router network no problems occurred. It was not until I tried to cascade the routers did this problem occur.

Update: I unplugged my Netgear router and plugged my PC directly to the Linksys and got the same connection drop. I tried it with my laptop over wifi connected to the Linksys and the same thing happened to the laptop. All other connections on any other device continues to work with no noticeable changes; the problem only occurs on the device using the P2P software.

Best solution

February 1, 2014 7:33:49 PM

So when you run a p2p (peer-2-peer torrents app I am assuming for the purpose of this response) the web browser and p2p application fail, but every other connection remains available? Can you ping the router interfaces--192.168.2.1 & 192.168.1.1--when you are in this situation?

If you are using the default settings in the router, then the subnet you are operating on is 255.255.255.0, meaning the available network space is 192.168.1.1 - 192.168.1.254, using 192.168.2.1 for your second router may cause problems if your routing protocol is not set up correctly. I would change it over to 192.168.1.2 for the secondary router (netgear), and disable DHCP on the secondary, the primary (linksys) should be your DHCP server. Also, you will need to change the settings for the DHCP IP ranges from 192.168.1.3 to 192.168.1.254, so your router does not assign anything else the IP address of 192.168.1.2 or 192.168.1.1 (the two IP addresses for your secondary and primary routers).

I was unfamiliar with the term cascading, but this link was quite useful. My response basically paraphrased the information from that particular webpage.

Back to your problem at hand though, the P2P issue. A possibility is one of your routers may be set to block p2p traffic, and an automatic response would be to temporarily block access to the particular device. Try switching up the port you are using for p2p and make sure your forwarding options are set up correctly. I believe you will need to configure port forwarding on both the primary and secondary routers. While you are in the configuration page, browse through the security section (if you have one) and see if there is any options related to blocking traffic

Here is a link on how to forward ports for your Linksys, and here is a link for your Netgear WNR2000.

My apologies if I seem confusing at any point in this response, it all makes sense in my head, but on these lengthy posts I sometimes jump around. Anyhow, hopefully the port forwarding options will fix your problem, but I can't imagine why it would limit the connections for your web browsers. All that should happen is your p2p program should have limited access to the internet, resulting in very slow download speeds. Best of luck to you and look forward to hearing back - Sub

*Edit* You may also want to try connecting your PC directly to your modem and see if you still have the same problem. With this we can narrow down if it is a router issue to start out with.
Share
February 1, 2014 7:34:54 PM

Seems after I reset my Linksys the DHCP server was only handing out IP for 192.168.1.100-150.. Promptly changed to 2-254 and no more obnoxious shutdowns. However, if I attempt to P2P or torrent on any other device at the same time as the pc, that device will continue to have the same issue. I still wish to resolve the problem but it seems to be more of an issue based on P2P conflicting with the specific router.
m
0
l
February 1, 2014 7:59:04 PM

Thanks for the reply SirSub42,
I had been considering switching to LAN to LAN rather than my setup but I am trying to keep my personal network (netgear) separated from the other (linksys). I had read that doing LAN to LAN setup makes my devices visible to the linksys or had I misread something?

I may setup a switch between the routers and modem later on if it is more efficient than the LAN to WAN method.
m
0
l
!