Solved

Seagate Barracuda 1TB Hard Drive - 7200RPM, 64MB, SATA Installation

Hello,

I am newly registered, but a frequent observer of the forums.

I am having an issue with my newly installed Seagate Barracuda 1TB Hard Drive - 7200RPM, 64MB, SATA 6Gb/s - ST1000DM003. I checked BIOS, and I see the drive under the "Speeding HDD", but that is the only place I can see it...so, it is being read, and has power to it.

I loaded up my PC, and when I went to Computer Management>Disk Management - it does not show my new 1TB drive. It on shows my OS (Windows 7) Drive (WD 320GB). I even did a "rescan" and still nothing is popping up.

I am at a loss, and have been searching the forums all day, and have had no luck.

Any information you could supply would be appreciated, and if there's any other information you need from me, please let me know, and I can post them as soon as I can.

I appreciate your time,
Denea
3 answers Last reply Best Answer
More about seagate barracuda 1tb hard drive 7200rpm 64mb sata installation
  1. Best answer
    If it doesn't appear under Disk Management then there's a Hardware issue likely.

    My guess is one of these two:
    1) Loose or defective SATA or Power Cable

    2) Defective drive.

    I think it's possible to detect the drive in the BIOS even if the power cable isn't attached but I'm not sure. I remember having an issue like this and it was a loose SATA cable (data or power).
  2. Thanks for the quick response, photonboy! I will check into tomorrow.
  3. Hello.

    I have an HP Z400, and am experience the same issue with the same Seagate Barracuda 1 TB hard drive.

    Please let me know if you discovered a fix.

    Kind regards,
    D'Aaron
Ask a new question

Read More

SATA Storage Hard Drives Seagate