ASUS Sabertooth x79 and Intel 4930k POST issue.

Hi, a few days back I put my new pc together and then ran into the usual no POST issue with the sabertooth and the intel 4930k, I have since read up and followed multiple BIOS flash guides to try and update my BIOS, everything responds as if the BIOS flash was a success (The lights flash for a bit, get faster then stop) however, still I get nothing when trying to power on my pc. I'm trying to update to BIOS version 4608, I've tried with two separate 8Gb USBs both formated to FAT32 and a 4Gb USB formated to FAT32. I've tried removing all ram individually, removing graphics cards and extra hard drives. Is there anything at all that I have missed? I'd love to get this fixed asap.
4 answers Last reply
More about asus sabertooth x79 intel 4930k post issue
  1. Hi. You may need to do rename the bios file.
    If using the 'USB BIOS Flashback' method then correct you must rename the .ROM file: SABERX79.ROM
  2. As far as I know the .ROM versions for the BIOS are all of the older ones and I'm trying to install the latest version so I have been using the .CAP files. However just to make sure I tried changing the .CAP file to a .ROM and when I tried to install the update the expected 2 flashes followed by a solid light occurred to imply that the update failed. To confirm, yes I have been re-naming the files to "SABERX79.CAP / SABERX79.ROM"
  3. Did you read this?
    http://event.asus.com/2012/mb/USB_BIOS_Flashback_GUIDE/

    *If your BIOS version is 1404 or older: Go to BIOS-Utilities to download and install the BIOS Converter utility before updating the BIOS.
  4. Yep, read that, just tried installing the converter now same result as trying to install a .ROM BIOS update, just blinks once then the blue LED just stays on, so no luck there unfortunately.
Ask a new question

Read More

Sabertooth Flash Intel Motherboards BIOS