Solved

Bought wrong memory Hyperx Blue 1333mhz

I bought the wrong RAM and Its gona be a hassle returning it, I have Hyperx blue 4gig 1600mhz and I bought 1333mhz.

I read many posts saying its a bad idea. But I checked the specs and they run at pretty much same voltage and the same latency.

Further more CPUZ says i AM running my 1600mhz at 1333mhz.

Here are the links :

Mine
http://www.kingston.com/datasheets/KHX1600C9D3B1_4G.pdf

The one I bought
http://www.kingston.com/datasheets/KHX1333C9D3B1_4G.pdf

CPUZ Specs

Frequency 672.5mhz

9.9.9.24

1.5v

System :
i5-3450k
ga-z77x-ud3h
HD7850

Have I wasted my money?
4 answers Last reply Best Answer
More about bought wrong memory hyperx blue 1333mhz
  1. you can try forcing it to run 1600 if it doesnt work you can always run both at 1333
  2. Best answer
    If CPU-Z is showing 672, that roughly equates to the sticks running at 1333 (actually 1344) so they are running together, could try manually setting to 1600, 9-9-9-26, 2T, and the DRAM voltage at 1.6 and see if they will run at 1600, might also need to add a bit of voltage to the CPU/VTT voltage - take it to 1.14 (it's your MC (memory controller) voltage
  3. Its not installed yet, the cpuz shows single slot for the 4gig. So worst case scenario they all run at 1333mhz and at best forcing them to 1600?
  4. Tradesman1 said:
    If CPU-Z is showing 672, that roughly equates to the sticks running at 1333 (actually 1344) so they are running together, could try manually setting to 1600, 9-9-9-26, 2T, and the DRAM voltage at 1.6 and see if they will run at 1600, might also need to add a bit of voltage to the CPU/VTT voltage - take it to 1.14 (it's your MC (memory controller) voltage


    Its not installed yet, the cpuz shows single slot for the 4gig. So worst case scenario they all run at 1333mhz and at best forcing them to 1600?
  5. Yep, 1333 is good, 1600 is possible
Ask a new question

Read More

Memory RAM