Help my ASUS m5a99fx pro memok dram blinks red! First boot!

Hey fellow computer scientists,

Just purchased a brand new system and can't get it to work. The motherboard light is green so I know their is power and the cpu fan turns on but I keep getting blinking red lights :(

-ASUS m5a99fx pro motherboard
-AMD fx 8350 4GHZ 16MB 125W AM3+CPU 8-core Processor black edition
-Corsair Vengeance blue 16GB 1600mhz RAM
-Thermaltake TR-700 700wt RT

Is my set up incompatible? Why are the lights blinking red while the motherboard light is green?

Best Regards,
11 answers Last reply Best Answer
More about asus m5a99fx pro memok dram blinks red boot
  1. Best answer
    Try reseating your RAM. Also are you using all the DIMM slots or just two. If you aren't occupying all the slots, make sure you have the RAM in the slots designated for just two DIMMs.

    If that doesn't help, does your motheboard have a Mem OK button? If it does, try pushing that and try booting.

    Also you could try resetting the CMOS.
  2. Thank you for the quick response techgeek! I reseated the ram three times just to make sure and still the light blinks red. Yes I press the MemOK button and it blinks red. Fyi this a first boot with everything being brand new just un-boxed today and I'm using a 1024mb gigabyte xlr8 performance edition just to test my computer before my r9 290 arrives in the mail.
  3. Do you have a case speaker? If so are you getting any beep codes? Does you motherboard have a POST indicator (seven segment LED's) and if so what code is it displaying?
  4. OK, went online and found a picture of your motherboard and no POST code display. Looks like beep codes are your best hope.
  5. Also check to make sure you have all power connectors plugged in. The ATX connector is obvious, but maybe you've forgotten the EPS 12V connector.
  6. Also you could try one stick of RAM at a time. Try one, if that doesn't work, then try the other.
  7. I forgot to plug in the epu 12v and now the lights stopped blinking :D and I got to the bios screen but now I get a cpu fan error but I have it plugged in? Also I tried to boot it off a HDD and it will show the windows logo upon boot but the motherboard will just turn off and restart?

    p.s. If it will make it easier I can post pictures?

    Thank you

    Update* Just noticed a solid red light boot_device_led
  8. Is the fan turning? In the monitoring tab, does the fan show a RPM?

    As for the booting off the HDD, was there an old install from another computer on it? If so, you'll have to do a full fresh install because the drivers that are being loaded for the old system will likely cause a BSOD or restart.
  9. Sorry S0nar, I've got to get some sleep. Good luck and keep us posted. Don't forget to assign best answer when your all done.
  10. Was this ever resolved? I've been up and down the related threads about this mobo/issue and there doesn't seem to be any particular resolutions. This is my 15th or so build, i've checked off all the 'noob' mistakes (power connectors, seating issues, etc) and i'm still getting the ASUS MemOK Red light of death. Anyone have any 'hail mary' ideas possibly not tested yet? I'm running the M5a99fx Pro R.2, FX-6300, Xfire XFX HD7870s, Corsair RM750, my custom water-cooling, GSKILL Sniper 16gb(8x2)..but all that is quite useless if the board won't get past it's own self tests :p
  11. It was solved by formatting & using a fresh install of Windows. My mistake was that I pulled a hdd from a older computer with Windows already installed.
Ask a new question

Read More

Light Motherboards