Sign in with
Sign up | Sign in
Your question
Solved

Ping spikes on wired and wireless connections

Last response: in Networking
Share
February 8, 2014 9:34:28 AM

Hey guys,

I have been experiencing ping spikes for the last couple of months on any computer in my house, be it wired or wireless. My ping shoots up to around 300ms from around 30ms periodically although it can be erratic. I am suppose to get 6mbps download but I notice this drops regularly to about 0.5mbps as well as the spikes.

I have contacted my ISP several times and they have sent out a few technicians who told us that there is no problem with our wiring/entry point in our house. They also said there is no problem with the exchange. When there is only one computer on my home network everything seems to run smoothly but if another computer connects the spikes occur. Both computers would likely be browsing the internet, streaming video or playing online games. This gets exponentially worse with more connected computers which is expected.

I understand that this sounds an awful lot like a congestion issue but surely my line should be able to hold a few computers connections concurrently without such a dramatic decrease in performance. If you want any more information/screenshots, please ask. I will post them as soon as possible.

I am just looking for some answers and greatly appreciate any response.

Thanks.
a c 110 F Wireless
February 8, 2014 10:12:34 AM

First thing of course to do is make sure you have the latest firmware on the router. Some routers have had strange things like this because of bugs.

With a 30ms ping you are obviously pinging something away from your house in the internet which makes it tough to find the problem.

So run a traceroute to some ip 4.2.2.2 and 8.8.8.8 tend to be good candidates since they are normally close to most locations.

Now open multiple command windows and ping continuously the first 2 hops as well as the final location do this from a wired connection. The first hop is the router inside your house. If you are having issues at this point I would be looking to replace the router...it is going to be hard to find out what exactly is making a router fail. If it is in the second hop this represents your connection to the ISP. It is normally some issue with the wiring but it could be your modem or the ISP router. It is highly unlikely it is your modem but it appears the ISP is already trying to blame it saying the wiring and exchange is ok. That does not mean it is but you will likely have to replace it to convince them otherwise.

If the delay is past the first couple hops then you are now in the giant cloud of the internet. You can if you work at it figure out where many of the hops are but getting them fixed is another story.

m
0
l
February 8, 2014 11:25:57 AM

bill001g said:
First thing of course to do is make sure you have the latest firmware on the router. Some routers have had strange things like this because of bugs.

With a 30ms ping you are obviously pinging something away from your house in the internet which makes it tough to find the problem.

So run a traceroute to some ip 4.2.2.2 and 8.8.8.8 tend to be good candidates since they are normally close to most locations.

Now open multiple command windows and ping continuously the first 2 hops as well as the final location do this from a wired connection. The first hop is the router inside your house. If you are having issues at this point I would be looking to replace the router...it is going to be hard to find out what exactly is making a router fail. If it is in the second hop this represents your connection to the ISP. It is normally some issue with the wiring but it could be your modem or the ISP router. It is highly unlikely it is your modem but it appears the ISP is already trying to blame it saying the wiring and exchange is ok. That does not mean it is but you will likely have to replace it to convince them otherwise.

If the delay is past the first couple hops then you are now in the giant cloud of the internet. You can if you work at it figure out where many of the hops are but getting them fixed is another story.



Thanks for your response.

I have updated the router's firmware and changed router (We actually bought a TP-LINK TD-W8980) as part of the ISP's suggested actions. The problem occurs on a few different routers.

I carried out the tests you suggested and here are my results.

Trace Route:


First Hop:


Second Hop:


Final Hop:


As you can see I cannot ping the second hop. Does this mean they do not allow that kind of traffic or is this a problem?
m
0
l
Related resources

Best solution

a c 110 F Wireless
February 8, 2014 1:56:55 PM

That just means they CHOOSE not to respond to ping.

Lucky for you the trace route showed the problem. traceroute normally does not send enough packets to see much.

Your problem starts in hop 2.

This is the most common place and lucky is the only one that you can get the ISP to help fix.

It is either the modem at your house, the wire, or the ISP device similar to your modem on their end.

The most common one is the wire or something like that. Since they "claim" they have tested the line I would replace the modem and then call them out to test again.

I hope this is not a wireless broadband connection. When I went to lookup the ISP that owned that IP i got vodaphone in ireland. The plans they offer talk about 70m fiber broadband and mobile broadband. They may not put up their other offerings so if this is DSL then that is a normal modem.

Wireless broadband is very iffy when you do not have access to LTE. Even LTE based stuff can get random strangeness.
Share
February 8, 2014 2:25:27 PM

bill001g said:
That just means they CHOOSE not to respond to ping.

Lucky for you the trace route showed the problem. traceroute normally does not send enough packets to see much.

Your problem starts in hop 2.

This is the most common place and lucky is the only one that you can get the ISP to help fix.

It is either the modem at your house, the wire, or the ISP device similar to your modem on their end.

The most common one is the wire or something like that. Since they "claim" they have tested the line I would replace the modem and then call them out to test again.

I hope this is not a wireless broadband connection. When I went to lookup the ISP that owned that IP i got vodaphone in ireland. The plans they offer talk about 70m fiber broadband and mobile broadband. They may not put up their other offerings so if this is DSL then that is a normal modem.

Wireless broadband is very iffy when you do not have access to LTE. Even LTE based stuff can get random strangeness.


Thanks again Bill for your response!

It is DSL Broadband that I have, they just don't advertise it. Our situation is a bit complicated when it comes to ISP because we switched from Eircom to Vodafone but Vodafone still uses Eircom's line. Basically if I want a technician to come out, I have to ring Vodafone and then they ring Eircom! Fibre is supposedly coming to my area in the Summer. Do you think I should just keep contacting Vodafone until the issue is resolved?
m
0
l
a c 110 F Wireless
February 8, 2014 3:20:32 PM

Yes it is highly unlikely it is the modem. I saw that 70m/sec fiber I wish I could ever think to get something like that.
m
0
l
February 9, 2014 5:08:17 AM

Thank you for all your help Bill.

I will change my modem and call my ISP tomorrow.
m
0
l
!