.NET 4.0 WIN7 x64: Nothing happens when I click the .exe to install.

I have tried running it as a standalone install and web. I have tried running both as Admin. I have heard that sometimes it can take a little while to start, but I have let it sit for hours and nothing.

This is a fresh install of windows and I have all updates. .NET updated through windows Update just fine but I cannot for the life of me get 4.0 to install. I am not a computer expert and I need help, please.
5 answers Last reply
More about net win7 x64 click exe install
  1. Right click the exe and go to properties. At the bottom right of the 'General' tab is a button that says 'Unblock'. Click that, then click 'OK'. Run the install and it should work fine. Downloaded exe files get flagged as not trustworty. Depending how your security is set, some will ask for permission to run, others won't do a thing.
  2. Thank you for your reply.

    I unblocked the .exe but it still won't run. I also tried getting 4.0 through Windows Update and that didn't work, either. Is there anything else it could be? Also I noticed that the programs show up in my Task Manager but they just sit there and do nothing.
  3. the net framework have to be install alone did you receive any error code for it from windows update .
  4. The only way I was able to install 4.0 (and 4.5) was by using .exes from a non-Microsoft website. After scanning the .exes before installing and running Malwarebytes, Spybot and Combofix after installing I think I can safely say I did not pick up any malware from the installs.

    The site was http://dotnetsocial.cloudapp.net/GetDotnet?rClrVer=v4.0 if anyone wants to check it out.

    My Windows computer hates Microsoft's website :)
  5. this is safe check with the kb2859818 on google fo more details .
Ask a new question

Read More

Framework Windows 7 X64