Sign in with
Sign up | Sign in
Your question

Weird fuzzy grey screen on my PC this morning

Last response: in Components
Share
February 12, 2014 3:51:17 AM

Hey, I booted up my PC this morning and I saw something I've never seen before.

It was a fuzzy grey screen and my TV was making loud popping noises, it looked and sounded almost exactly like one of those old analogue channels that isn't tuned properly. I had to force my PC off with my power button to make it stop, then when I booted up again, it started up as normal.

I double checked my antenna channel to make sure it wasn't that and it was definitely the HDMI channel which my PC is connected to.

What could be causing this? I'm hoping it doesn't happen again, is it likely to be the graphics card? since my HDMI cable connects into it?

Here's my system specs.

MSI 660Ti PE
8GB RAM
Intel Core i5 3570K
MSI Z77A-G45
650W Corsair Enthusiast Series 650T
128GB SSD
1TB HDD
February 12, 2014 4:15:57 AM

It's most likely the GPU failing that's causing that, try and see if the VGA connector does the same (if availiable).
m
0
l
February 12, 2014 4:58:10 PM

hairystuff said:
It's most likely the GPU failing that's causing that, try and see if the VGA connector does the same (if availiable).



Unfortunately I don't have a VGA cable available, however I haven't been able to get it to trigger again with the HDMI cable, not sure if it was a one off glitch or perhaps it really is failing.

Perhaps I should fire an email to MSI or point of purchase to see if they've heard of the problem before.
m
0
l
February 13, 2014 4:58:35 AM

That might be worth doing plus if you can provide them with a picture of the glitch that would also help.
m
0
l
!