ASUS Sabertooth 990FX R2.0 ATX AM3 Boot Device LED and other issues

I was having issues with my system not turning on, and so I ended up buying a new mobo and processor. When I put my new Sabertooth mobo and AMD FX-8350 processor together with the rest of my hardware I found that I had the exact same issues, so I breadborded it and found that it was my video card that was the issue. I sent it in for replacement and put in my old HD XFX Radeon 6870 and I finally had a working desktop again.

I did a clean install on my hard drive and everything was working just fine for less than a month. Then a few days ago my system started shutting down just out of nowhere like the power button had been pressed. I checked my event viewer and the system got a call from the Kernel to shut the system down. I went into my system properties, clicked settings for 'Startup and Recovery' and unchecked 'Automatically restart' under 'System failure', and that stopped the automatic shutting down. Just a day later I'm using my system and I need to restart it and I do so. When I do it loads the bios screen, the windows loading screen, and then the screen stays black and nothing happens. I restart the system again, this time the Windows Recovery screen appears because Windows did not start last time. When Windows Recovery is done analyzing and asks me if I would like to recover, I cannot click the button with my mouse or my keyboard, which is very odd because I was able to select 'Windows Recovery' when it asked me if I wanted to recover or start windows normally. I restart the computer again, this time it does not get past the bios screen, I can't even get into the bios, and the boot_device_led light is on.

This is where I am stuck, my system will either stay stuck on the bios screen with the boot_device_led light on, or it will get to system recovery but I can't recover because my mouse and keyboard are no longer recognized. I put in my Windows 7 disk and tried to do a fresh install but it has the exact same issue of not recognizing the keyboard or mouse.

I've tried plugging in a PS/2 keyboard and it still wouldn't recognize it on the Windows Install or Windows Recovery screen. I've tried booting without the ram, the video card, or the extra hard drive. I have no idea what to try next. The only control I have is in the bios menu.

System Specs:
MOBO: ASUS Sabertooth 990FX R2.0 ATX AM3\
CPU: AMD FX-8350 8 Core Processor Socket AM3+
GPU: HD XFX Radeon 6870
RAM: x2 khx1600c9d3k2/8gx and x2 f3-12800cl7d-4gbrh
HD: 128GB SSD Crucial, and 1TB SATA WD10EARS
2 answers Last reply
More about asus sabertooth 990fx atx am3 boot device led issues
  1. What power supply.
  2. SR-71 Blackbird said:
    What power supply.


    SR-71 Blackbird said:
    What power supply.


    It's a rocketfish 750 watt PSU from 5 years ago.
    That doesn't matter now, I can get to the Windows desktop now if I choose not to go to Windows Recovery. I'm not getting stuck on the Bios screen with the boot_device_led anymore.
    I'm re-installing Windows 7, but I have to do it from the desktop, I can't do it from boot. This doesn't make sense because I initially installed Windows 7 on the system with all of the hardware I have now from boot. It just will not recognize the mouse or keyboard in Windows 7 install or Windows recovery from boot.
    Does this make any sense at all? Because it doesn't to me.
Ask a new question

Read More

Sabertooth Hardware Issue Motherboards CPUs