Sign in with
Sign up | Sign in
Your question

MSI B75A-G43 BIOS update fail

Last response: in Motherboards
Share
February 18, 2014 6:22:44 AM

I've just updated my 1 year old B75A-G43 to the lastest BIOS via UEFI BIOS M-Flash mode, which is the E7758IMS.AA0 aka version 10.10, my previous BIOS version was 10.4 or 10.3 (E7758IMS.A40), but the problem is when it appeared at 44% of the completion, the PC suddenly shutdown and I let it stay for 40 minutes at the black screen, then it started to reboot with a 3-5 seconds of breathing and power off again. I did remove the CMOS battery for several times too. After all, I think the motherboard itself now is a brick.

So is there any idea for me to reflash/recover the BIOS? Please help. Thank you.
a b V Motherboard
February 18, 2014 6:29:55 AM

tried resetting the jumper?
m
0
l
February 18, 2014 6:40:19 AM

I did, no help...
m
0
l
Related resources
a c 1356 V Motherboard
February 18, 2014 8:12:55 AM

Sounds like you may have bricked the board.
m
0
l
a b V Motherboard
February 18, 2014 8:19:02 AM

did you do it the m-flash way?
m
0
l
February 18, 2014 8:43:28 AM

@satyamdubey: Yes.n I plugged the USB flash drive into the front panel USB 3.0 port.
I bought it 1 year ago and last night was my first day using it, it has only been used for 3 hours...
m
0
l
a b V Motherboard
February 18, 2014 8:47:37 AM

there is a good chance that the mobo would require an rma as has already been suggested by blackbird but as a last resort, can you stick the flash drive in one of the rear ports and see if it helps?

-Satyam
m
0
l
!