Sign in with
Sign up | Sign in
Your question
Solved

Asus Sabertooth x58 RED Cpu and dram Led

Last response: in Motherboards
Share
February 18, 2014 10:36:52 AM

After I got my power supply to work and all I came across another problem. I was able to boot my pc twice after the new power supply was installed. After closing the case door to my pc I tried to boot it up again. Everything turned on, fans,leds,etc. Only thing is nothing appeared on my monitor. So I opened my case back up and saw 2 bright leds. Dram and cpu led. Not sure whats wrong. I just installed a new power supply because my old one died. I did not touch the cpu and all the cables are plugged in. 24 pin and 8 pin. I tested all of my ram on another pc and they all work.

Specs:
Motherboard: Asus Sabertooth x 58
Cpu: i7 920
Gpu: Asus Gtx 650Ti
Ram: 6x1 Ocz 1333mhz
Power supply: Enermax 85+ 1050w

Thanks-Darren
a b ) Power supply
a b V Motherboard
a b à CPUs
February 20, 2014 4:54:53 PM

Try booting with only one stick of RAM in.
m
0
l
February 21, 2014 11:03:41 AM

I have tried booting with 1 stick still nothing.
m
0
l

Best solution

March 12, 2014 11:08:16 PM

I just had this very issue. I was installing a fresh OS on a separate drive and right as the computer did its final restart, the display just went black. No signal going to the monitor, two red lights on DRAM_LED and CPU_LED, it was just as you had described. I did what I've described below and it now seems that my motherboard can only pick up one drive via SATA at a time, which is why I tell you to make sure you only plug in the drive you plan on booting from. Not sure exactly what's caused this, or what I have left to do before everything is working as it once was, but I'm happy to be browsing the net and listening to music again, so hopefully this will at least get you to that point.

SOLUTION:

  1. Make sure you only plug in the drive you plan on booting from
  2. Clear RTC RAM as described in section 2.6 Jumpers of the manual here
  3. Set everything in your BIOS to the default settings


    Share
    !