Solved

Asus Z87 Deluxe/quad q-code AE, Blank screen, no bios options

I built my first computer last night and was seriously disappointed when i turned it on and got nothing on the screen. No bios options and a Q-code of AE (Legacy Boot Event). I have tried un-hooking one of the memory cards, un hooking the GPU, and trying the monitor on the gpu and on the mother board. I don't know what else to do and im startting to get worried that i just flushed $2500 down the drain. I used this sight for a lot of my research viewing others problems and answers and reading advice about components. Hopefully some can help me. My build is below.

Mother Board: Z87 Deluxe Quad
Memory: Corsair vengance 1866
CPU: i7 4770K
SSD: Samsunge evo 750Gb
HDD: WD grenn 4TB
GPU: Asus HD7770
CPU cooler: Corsair H80i
Power supply: Corsair CX750
Case Coolermaster Haf-X Full
3 answers Last reply Best Answer
More about asus z87 deluxe quad code blank screen bios options
  1. Are you sure you did not bend any of the pins when you installed the CPU?
  2. look at the last four number of the mb serial number that the bios rev of the mb. se if it close to the 1707 that on asus web page. if it old try using the usb flashback if the mb has it to update the bios.
  3. Best answer
    Sorry for the late response here. I really do appreciate the help. I uninstalled and reinstalled the memory. I also changed which sata ports I plugged the HDD's and SSD into and I was able to get a picture. After installing windows 8.1 everything works great now.
Ask a new question

Read More

First Build Mother Board Motherboards