Sign in with
Sign up | Sign in
Your question
Solved

Asus Z87 Deluxe/quad q-code AE, Blank screen, no bios options

Last response: in Motherboards
Share
February 20, 2014 10:14:45 AM

I built my first computer last night and was seriously disappointed when i turned it on and got nothing on the screen. No bios options and a Q-code of AE (Legacy Boot Event). I have tried un-hooking one of the memory cards, un hooking the GPU, and trying the monitor on the gpu and on the mother board. I don't know what else to do and im startting to get worried that i just flushed $2500 down the drain. I used this sight for a lot of my research viewing others problems and answers and reading advice about components. Hopefully some can help me. My build is below.

Mother Board: Z87 Deluxe Quad
Memory: Corsair vengance 1866
CPU: i7 4770K
SSD: Samsunge evo 750Gb
HDD: WD grenn 4TB
GPU: Asus HD7770
CPU cooler: Corsair H80i
Power supply: Corsair CX750
Case Coolermaster Haf-X Full
a b V Motherboard
February 21, 2014 11:08:38 AM

Are you sure you did not bend any of the pins when you installed the CPU?
m
0
l
a c 462 V Motherboard
February 21, 2014 1:45:03 PM

look at the last four number of the mb serial number that the bios rev of the mb. se if it close to the 1707 that on asus web page. if it old try using the usb flashback if the mb has it to update the bios.
m
0
l

Best solution

February 22, 2014 7:32:44 PM

Sorry for the late response here. I really do appreciate the help. I uninstalled and reinstalled the memory. I also changed which sata ports I plugged the HDD's and SSD into and I was able to get a picture. After installing windows 8.1 everything works great now.
Share
!