Sign in with
Sign up | Sign in
Your question
Solved

Router able to use ethernet over copper connection from bridged netvanta 838 for 6 different public ip LAN subnets

Last response: in Networking
Share
February 21, 2014 3:37:16 PM

*all ips in this post are not the actual ips but random dummy public ips to help better see the issue.

Please provide me with a router or a firewall/router that can accomplish this.

I have an Ethernet over copper connection that is terminated with an Adtran netvanta 838(The Adtran 838 is a Bridge and has no ability to be put in Routed Mode. An Ethernet Router is required in order to use the service and should be connected to Ethernet Port 1 using the following WAN Info.

This connection is assigned a WAN ip and 6 different public LAN ip blocks of varying sizes. I will have 6 servers connected to 6 ports and the servers will have all public LAN ips statically assigned, I will only use two here since that will suffice to scale out to all 6 - ie.

server1 will have eth0:2-eth0:254 statically assigned 77.158.110.2 thru 77.158.110.254 with a gateway of 77.158.111.1(gateway may need to be wan gateway?)

server2 will have eth0:2-eth0:127 statically assigned 75.10.114.2 thru 75.10.114.127 with a gateway of 75.10.114.1( gateway may need to be wan gateway?)

The servers will have websites assigned to each of the public ips and need to be accessible from the internet if someone tries to reach a website hosted on any of these ip addresses.

the servers cannot have private ips that are 1 to 1 natted or any other method that gives them private ips. Can I accomplish this? Any help would be very much appreciated.


Port 1/WAN port
ipaddress 83.235.25.110
connected to EOC Adtran netvanta

Port 2
ipaddress 77.158.111.1
connected to server1 eth0(split to eth0:2 thru eth0:254)

Port 3
ipaddress 75.10.114.1
connected to server2 eth0(split to eth0:2 thru eth0:127)



WAN IP: 83.235.25.110
255.255.255.252
WAN GATEWAY:83.235.25.109

LAN IPS:
77.158.111.0/24
75.10.114.0/25
a b X LAN
February 21, 2014 3:50:34 PM

You will likely need a commercial router or firewall. Both juniper and cisco sell device. If you only need the routing a layer 3 switch would also work.

do you want all the ip's in the subnet to go to a single server or do you want them to go to many.

Real IP are valuable so you do not want to waste them to communicate. Let say on port 2 of the router you defince 10.10.2.1/30 and assign the server 10.10.2.2. You could then router he entire /24 to the 10.10.2.2. The server would then be responsible for using the addresses.

Now this also works even if you say only had a /30. Say they give you 47.1.1.192/30 If you use it as a point to point you only can run 1 server. A better way to do this is to configure the server to use a loopback address. You would then router 47.1.1.192/32 47.1.1.193/32 etc to 4 different servers. The servers would just have to be smart enough to source the packets with this loopback address.


Now if you are really ambitious you can do this with a dd-wrt router also.
m
0
l
February 21, 2014 4:37:05 PM

thank you so much for the quick reply!

bill001g said:


do you want all the ip's in the subnet to go to a single server or do you want them to go to many.



I want all the ip's in the subnets of the /24, /25, /26, /27, /28 to each go to their own individual single server that has all the corresponding ips statically assigned. The /29 subnet port could have another switch that could go to a few computers and maybe a voip phone as well. (this is not required though I just need the servers subnets to work correctly)


bill001g said:

Real IP are valuable so you do not want to waste them to communicate. Let say on port 2 of the router you defince 10.10.2.1/30 and assign the server 10.10.2.2. You could then router he entire /24 to the 10.10.2.2. The server would then be responsible for using the addresses.


Yes I think you are describing what I am trying to accomplish here.


bill001g said:


Now this also works even if you say only had a /30. Say they give you 47.1.1.192/30 If you use it as a point to point you only can run 1 server. A better way to do this is to configure the server to use a loopback address. You would then router 47.1.1.192/32 47.1.1.193/32 etc to 4 different servers. The servers would just have to be smart enough to source the packets with this loopback address.


Now if you are really ambitious you can do this with a dd-wrt router also.


I'm not sure if this is what I need done, the loopback on my servers is normally for localhost( not sure if you are talking about something different or another way of configuring it).

I do have a cisco SG300-10 L3 switch, a zywall USG 50 firewall, and a Linksys WRT54G2 router. I have tried to get the information I need to set this up on the L3 switch but cisco hasn't been able to provide me it and some of the engineers think its not possible despite what my research on L3 devices says. I might have to make it work on this crappy linksys since I did find it on the dd-wrt site.

If there is a device that would be easy to setup in the manner I require I will purchase that since it has been very difficult trying to get this L3 switch to work.
m
0
l
a b X LAN
February 21, 2014 6:04:31 PM

I guess that is a cisco l3 switch but it is not the normal IOS based ones I am used to so it is likely really a linksys.

I could give you the commands if this was ios but you are going to have to figure out how to do this.

The simplest way is to define one big vlan and put all the servers in it. Say you use 10.10.10.100/24 for the switch ip. Then assign server 1 10.10 10.1/24 server 2 10.10.10.2/24 etc. Now put in static routes for say x.x.x.x/24 and point it to 10.10.10.1 and then y.y.y.y/25 and point it to 10.10.10.2. All the severs would have a default to 10.10.10.100 You would put all ports except the one going to the internet in the same vlan. For that one you would need another vlan interface that has the wan address. Be aware most l3 switches can not do nat.

You of course can define one vlan per server. ie vlan 1 is 10.10.10.1/30 with x.x.x.x/24 send to 10.10.10.2 and vlan 2 is 10.10.10.5/30 with y.y.y.y/25 sent to 10.10.10.6.

Now this assumes you have figured out how to make a server actual use all those addresses. I am not a server guy.

If all else fail I am going to bet the zwall supports vlan tags. What you do is pretty much the same thing except put the routes in the zywall. You will run the switch layer 2. You would define all your vlans the same way and put the servers in whatever ports you like. Then you would assign all the vlans to the port going to zywall as tagged. This would allow you to define the virtual interfaces on the zywall. I am too lazy to go read the manual on the zywall but I suspect it must support this.
m
0
l
February 21, 2014 7:09:53 PM

bill001g said:
I guess that is a cisco l3 switch but it is not the normal IOS based ones I am used to so it is likely really a linksys.

I could give you the commands if this was ios but you are going to have to figure out how to do this.

The simplest way is to define one big vlan and put all the servers in it. Say you use 10.10.10.100/24 for the switch ip. Then assign server 1 10.10 10.1/24 server 2 10.10.10.2/24 etc. Now put in static routes for say x.x.x.x/24 and point it to 10.10.10.1 and then y.y.y.y/25 and point it to 10.10.10.2. All the severs would have a default to 10.10.10.100 You would put all ports except the one going to the internet in the same vlan. For that one you would need another vlan interface that has the wan address. Be aware most l3 switches can not do nat.

You of course can define one vlan per server. ie vlan 1 is 10.10.10.1/30 with x.x.x.x/24 send to 10.10.10.2 and vlan 2 is 10.10.10.5/30 with y.y.y.y/25 sent to 10.10.10.6.

Now this assumes you have figured out how to make a server actual use all those addresses. I am not a server guy.

If all else fail I am going to bet the zwall supports vlan tags. What you do is pretty much the same thing except put the routes in the zywall. You will run the switch layer 2. You would define all your vlans the same way and put the servers in whatever ports you like. Then you would assign all the vlans to the port going to zywall as tagged. This would allow you to define the virtual interfaces on the zywall. I am too lazy to go read the manual on the zywall but I suspect it must support this.


It does have the IOS that I can program from the command line or a running-config text file that I can upload.

The ips on the server are easy :) 

Trust me you are not lazy in the slightest; you're help has gone above and beyond for a forum.
m
0
l

Best solution

a b X LAN
February 22, 2014 4:26:28 AM

So 2 partial sample configs then. You will have to modify to match your ports etc. I am keying this without a real switch so I may make typo.

.....I am going to assume you can put ip directly on the ports on this switch if not you need to create vlan interfaces.

ip routing.
int g0/1
desc wan
IP address 123.123.123.1 255.255.255.252
int range g0/2 - 10
switchport
switchport mode access
switchport access vlan 10
spanningtree portfast
int vlan 10
desc connection to servers
ip address 10.10.10.100 255.255.255.0
Ip route 222.222.222.0 255.255.255.0 10.10.10.1
ip route 223.225.225.0 255.255.255.128 10.10.10.2
ip route......
IP route 0.0.0.0 0.0.0.0 123.123.123.2


example 2 using all point to point
ip routing.
int g0/1
desc wan
IP address 123.123.123.1 255.255.255.252
int g0/2
desc server 1
ip address 10.10.10.1 255.255.255.252
int g0/3
desc server 2
ip address 10.10.10.5 255.255.255.252
int g0/4
desc server 3
ip address 10.10.10.9 255.255.255.252
.......
Ip route 222.222.222.0 255.255.255.0 10.10.10.2
ip route 223.225.225.0 255.255.255.128 10.10.10.5
ip route......
IP route 0.0.0.0 0.0.0.0 123.123.123.2

Share
!