Sign in with
Sign up | Sign in
Your question
Solved

deleted raid framework and now pc wont boot.

Last response: in Storage
Share
February 25, 2014 7:42:07 PM

This is long and complicated but i will do my best to describe what happened. If you do not want to read the background i put up to help explain my situation skip to the second to the last paragraph for my problem in a nut shell and my question.

To start, ever since i built my PC this august i have had problems with my hard drive. I wanted to reuse the hard drive from my old pc and put it in my all new pc i built from the ground up. The only reused parts in the new pc being the hard drive and cd drive. I know your suppose to install windows fresh and wipe your hard drive when putting it into a new build but i didnt want to loose my data and operating system so i did not do that.

To make a long story short the reused hard drive would not boot in the new pc i built unless i had it set to raid mode even though i was only using one hard drive. If i set it to ACHI or IDE i would get an endless loop and never get to windows. Anyway i filled up that old 500 GB hard drive and bought a new western digital blue 1tb hard drive. I used AEOMI software to transfer the os and all data from my old hard drive to the new one. All was fine and i didnt bother trying to run both harddrives together and just used my new 1tb in raid mode(its the only mode that it will boot).

Heres where the real problem starts. I finally filled up my 1tb hard drive and i decided i was going to hook up my old 500 GB harddrive and run that with my 1tb so i had more storage space. Now is when i killed everything.

I went into the raid configurations and made a raid volume for my two harddrives. Well i dont know if that was what i was suppose to do to get the two harddrives working together but thats why i thought i would try. To make it short it would not boot that way.Upon seeing that that did not produce the results i desired i decided to delete the raid volume and just boot off my 1tb(as i always do) and just ask the toms community how to properly set my two harddrives to work together. Anyway when i tried to delete the raid volume i deleted the 'RAID framework" from both hard drives because i thought i just made that framework when i made the raid volume, but i now suspect that was already on those hard drives and that is what caused my problems now.

So here is what it is doing now, i have my single 1tb western digital blue hard drive that has my legal copy of windows 7 64 bit on it set as the main drive to boot from. When i try to boot i get the message "reboot and select proper boot device or insert boot media in selected boot device and press a key" Before i messed with everything i always booted from that hard drive with no problems.

My question is what did i do to my hard drive to cause it to do this(i have a feeling it was deleting the raid frame work from the harddrive since i always had to boot that hard drive in raid mode an dnot achi or ide because ACHI or IDE causes an endless loop and i cannot get to windows) and is there a way to fix this without having to buy a brand new copy of windows 7 64 bit. The copy of windows i have was from my old hard drive in my old pc i bought from a friend and i do not have access to the disc or product code, i know its legal because it never came up and said anything like your copy of windows in not genuine like my friends pirated copy of windows says in the bottom of the screen so that cannot be what is causing my problems.

Any help i receive is sincerely appreciated as my pc is now rendered inoperable due to my stupid messing around with sh** i didnt have enough knowledge with(lesson learned)

Best solution

a c 107 G Storage
February 26, 2014 9:59:01 AM

To fix this you need to re-install Windows on the drive with whatever drive setup you want to use. I suggest just ACHI. A Repair setup of Windows on the drive when you set it for RAID should work and that won't wipe your data, but it may not work without a full clean setup. You can get whatever version of Windows you have a license for from here http://answers.microsoft.com/en-us/windows/forum/window... to run the setup if you don't have the disks.

Does the computer have an OEM license or a retail one? You may need to check with your friend. Just because you don't have a message about an illegal Windows copy does not mean yours is not.
Share
a c 819 G Storage
February 26, 2014 7:57:34 PM

Uhmmm. when creating the raid volume and the message came up that it would delete the contents of both drives, why did you say ok?

I'm not sure now if your data is recoverable and a complexly bootable drive is probably not going to happen.

try r-studio, raid reconstructor, or reclaimme and see if they can see your raid ready single drive (keep the 500 out of it for now) and how much data is being used..
m
0
l
February 28, 2014 12:26:50 AM

Thank you both for the help, i ended up talking to my friend who sold me the original hard drive with windows on it and it turns out it was pirated:( . I ended having to buy a legal copy of win 7 64 bit and install that onto my hard drive, and i was really,really hoping that would not delete all my data but it mostly did and i the only things i was able to recover when i put my HD into my friends pc were my music,video,and document files i had on my pc...(hang the 9,i read your post with the advice of running repair and not doing a clean install after i had done a clean install of win 7):I lost all of my games and software, but the good news is most of my games were from steam and origin so i can download them for free again and keep my game saves. The only big problem now is that i heard comcast has a 250GB a month cap, and with my steam and origin games alone i have 200GB of data to redownload:( .

Anyway thanks again for the help, this has been stressful but at least i learned that it is not a smart thing to try and learn by trial and error when messing with hard drives.

P.S. popatim, when i created the raid volume it did not ask if i wanted to delete the contents of the drives. When i created the volume everything was fine, but when i tried to boot after making the volume it just went black when trying to get into windows. I then figured the raid volume was causing my problems so i went back into the bios and tried to disband the raid volume but it would not let me do that unless i agreed to delete the "raid framework" from both drives. I thought the computer created a raid frame work when i made the raid volume and i had no idea the framework was preexisting on the drives and was apparently vital to them being able to boot:( .

I know it was confusing trying to understand that because of my huge wall of text, i just like to try and explain everything and not leave anything out so i put too much info and people get confused, so my apologies for that.Thanks for the links and taking the time to try and help, my friend and i used many programs (im not sure if any were the ones you linked to, but im willing to bet at least one was) to try and find my drive and when it was found it was unallocated and it was a huge mess.
m
0
l
!