Sign in with
Sign up | Sign in
Your question
Solved

Why won't my newly built PC display video?

Last response: in Systems
Share
February 26, 2014 2:31:50 PM

I've built this computer. When I power it on, all of the fans work, the lights come on, the DVD drive works, and it had no beeps. With that being said, there's not output video. I've tried it on two different monitors with HDMI and VGA connection. Can someone please take a look to see if I 'am missing anything? The only thing I can think of being the problem is maybe the hard drive, being that a friend gave me the drive as he had it lying around. Any feedback would be greatly appreciated.

Motherboard: MSI FM2-A75MA-E35
http://www.amazon.com/gp/product/B009HP42HQ/ref=oh_deta...

CPU: AMD A10-5800K APU 3.8Ghz
http://www.amazon.com/gp/product/B0095VP8D4/ref=oh_deta...

PSU: Corsair Builder Series CX 430 Watt
http://www.amazon.com/gp/product/B0092ML1SC/ref=oh_deta...

RAM: Kingston ValueRAM 4GB 1600MHz DDR3
http://www.amazon.com/dp/B0084IEU60/ref=pe_385040_30332...

HDD: 320 GB Western Digital HDD (I got this hard drive from a friend of mine. He used it in another computer and had it lying around)
February 26, 2014 2:52:16 PM

"No video output" problems can be caused by a number of issues. Perform all the steps in this troubleshooting checklist and let us know how it goes.
"No POST", "system won't boot", and "no video output" troubleshooting checklist
"No POST", "system won't boot", and "no video output" troubleshooting checklist This checklist is a compilation of troubleshooting ideas from many forum members. It's very important to actually perform every step in the checklist if you want to... See full content
m
0
l
February 26, 2014 5:42:04 PM

I've went through this checklist, but it seems that it didn't do the trick. I'm still having the same issue.
m
0
l

Best solution

March 1, 2014 11:02:04 PM

many times the FM2A75MAE35 mobo will have a problem displaying from the APU, it seems the only fix is to call MSI and have them send you another mobo, or to try a different BIOS setting, get a seperate graphics card, borrow one if u cant, then simply set up the computer, go into the settings, and fix it from there, i have to do that every time i buy this mobo, even though it is a great one for the price
Share
!