Sign in with
Sign up | Sign in
Your question
Solved

Slow RAID 0 Write Speeds; TRIM not working?

Tags:
  • Storage
  • Kingston
  • Speed
  • NAS / RAID
Last response: in Storage
Share
March 3, 2014 8:31:38 PM

Ok I am running 2x128gb Kingston v300's in raid 0 as my boot drive. I am using a z87-a motherboard, windows 8.1. I ran Crystal Disk mark and am finding that I am getting 400+ MB/s read speeds on random fill, but only 180 MB/s write speeds unless I select 0 fill. I am wondering why this is?

I searched extensively, tried everything, and I doubled back to TRIM, finding that while the command prompt tells me it is activated, TRIMcheck says that it is not working.

I'm wondering if this is a problem with the Intel Rapid Storage Technology Drivers. Do I need to change something in the BIOS to properly configure these drivers? If anyone has had any experience with this before any advise would be greatly appreciated!

Thanks,
Kieran

More about : slow raid write speeds trim working

Best solution

a b G Storage
March 3, 2014 8:41:22 PM

This article might answer your question:

http://www.anandtech.com/show/7763/an-update-to-kingsto...

Share
March 3, 2014 9:11:07 PM

Martell1977 said:
This article might answer your question:

http://www.anandtech.com/show/7763/an-update-to-kingsto...



Ok, well that is dissapointing, I have the 506A firmware, and the speeds on that chart match up almost exactly for incompressable data. But thanks for that information! Any advice on what to do now if anything?

While that does explain the speed problem, I'm still curious as to why TRIMcheck is saying that the trim function is not working. Is there a problem with IRST communicating to the chipset or is something else going wrong?
m
0
l
a b G Storage
March 3, 2014 9:23:57 PM

“The title says it all. Fsutil will tell you if TRIM is enabled or not, but it won’t tell you if it is really functional. TRIMcheck will actually check and verify whether TRIM works or not. This program has no GUI, it runs in a command prompt window. You must copy it on the SSD that you are testing and run it twice, waiting at least 30 seconds to a minute between runs in order to ensure accurate results. When executed for the first time it will write on specific locations on the SSD. It will then delete the written data and exit. When you run it a second time a minute later, it will try to read the exact same locations.

When TRIM works you’ll get zeroes on the sectors it wrote, plus a notification that TRIM works. If the data is still there, you’ll be notified that TRIM is not working. If you get a negative result and fsutil tells you that TRIM is enabled anyway, try to wait 10 minutes or so before running it for a third time. This program is great for cases where certain software use cheap workarounds that cripple TRIM in order to ensure SSD compatibility. In such cases fsutil will show that TRIM is enabled, regardless if it really works or not. With this utility you’ll know for sure.”


From:
http://www.thessdreview.com/daily-news/latest-buzz/trim...

Considering what they did with the NAND, this might be the case as well. If this is also the case, Kingston has really dropped in quality...sad.

m
0
l
!