Solved

why can't HWMonitor can't read cpu temps after upgrade?

So I just upgraded from a 5800K to a 7850K. I have a G1.Sniper A88X. I used BIOS version F2 with the 5800K and had to update that to use the Kaveri. HW monitor used to read cpu temps with the 5800k but now it doesn't even have a line showing CPU temps. BIOS readings show around 50C, Speccy also doesn't show readings, EasyTune6 shows 23-25C on idle. That can't be right, I'm using the AMD stock cooler(will buy NH-D14 soon) so temps should be higher.

I need to read temps so that when I get an aftermarket cooler I can test what the idle and load temps are for OC purposes.

Anyone know why?

EDIT: Oh and the readings on AMD Overdrive is whacked. Turning off the boost(lowers the clock) gives readings of steady 70C on all cores. Turning on the boost(increases the clock) makes it jump around 60-70.
12 answers Last reply Best Answer
More about hwmonitor read cpu temps upgrade
  1. scout_03 said:
    did you try this one http://www.hwinfo.com/download.php


    It show "N/A" on the temp monitor column :/
  2. what is the bios you have in now and did you have the latest chipset driver for the motherboard also the sensor part on this cpu could be defective try to contact amd about this and let see what they will answer .
  3. scout_03 said:
    what is the bios you have in now and did you have the latest chipset driver for the motherboard also the sensor part on this cpu could be defective try to contact amd about this and let see what they will answer .


    I updated to the beta BIOS F8b but I downgraded to F7. Also after running HWiNFO with the Sensors only option there seems to be a reading on my processor. Under "CPU [#0]: AMD A10-7850K" there's a line "CPU 0 Package" reading about the same as the one in the BIOS. Jumps around 50-60C, idle. Don't know if that's the right one but I wonder why the other software can't read the cpu temps. Are there BIOS settings that could interfere with the readings?
  4. for a amd a 10 your idle temp is high since there are suppose to be cooler i got a phenom 11 x 3 720 and it read 35 ccurent max 40 c for this session and never goes over 60 c under high load,i would suggest you recheck the pasting under the cooler and use a good one to repaste then carefully refix the cooler if this is not solving the temp issue i would try a rma for a defective cpu .
  5. scout_03 said:
    for a amd a 10 your idle temp is high since there are suppose to be cooler i got a phenom 11 x 3 720 and it read 35 ccurent max 40 c for this session and never goes over 60 c under high load,i would suggest you recheck the pasting under the cooler and use a good one to repaste then carefully refix the cooler if this is not solving the temp issue i would try a rma for a defective cpu .


    Damn. What's the temps supposed to be when using stock speed and stock cooler for the 7850k? I think my room/ambient temperature is around 20-25C. I don't have a room thermometer though.
  6. Best answer
    i found something they use the same board you have and temp are 49 c http://www.hardwareheaven.com/reviews/1918/pg2/amd-a10-7850k-kaveri-apu-review-featuring-gigabyte-g1sniper-a88x-g1-sniper-a88x-motherboard.html so check there setting your cpu could be defective .
  7. scout_03 said:
    i found something they use the same board you have and temp are 49 c http://www.hardwareheaven.com/reviews/1918/pg2/amd-a10-7850k-kaveri-apu-review-featuring-gigabyte-g1sniper-a88x-g1-sniper-a88x-motherboard.html so check there setting your cpu could be defective .


    Oh lol... I just read a forum post on AMD. http://forums.amd.com/game/messageview.cfm?catid=483&threadid=171190&enterthread=y

    The other temperature monitors may still not have support for Kaveri APUs. And I checked the changelog of HWmonitor and it didn't explicitly say it supported kaveri apus, only FM2+ motherboards. Also I'm gonna try installing the Beta 14.2 catalyst drivers if that has any effect.
  8. the catalyst driver are for the gpu you need to check with your motherboard maker for the driver uptade on the chipset or the bios for the cpu .
  9. scout_03 said:
    the catalyst driver are for the gpu you need to check with your motherboard maker for the driver uptade on the chipset ot the bios for the cpu .


    Already updated the chipset drivers to the latest from Gigabyte's site. Strangely, for some reason using the only software that can read my CPU's temps, it's now idling around 46C-49C. Really strange. Oh well, it'll get cooler once I buy that NH-D14. Just waiting to see if someone buys my old processor or motherboard.

    Thanks for all the help scout_03.
  10. your welcome ,if you sell them toghether they wont be hard to sell .
  11. try right clicking and launching the programs as administrator
Ask a new question

Read More

BIOS CPUs