Sign in with
Sign up | Sign in
Your question
Solved

Can't solve this: Crosshair V Formula Z video card issue

Last response: in Motherboards
Share
March 4, 2014 10:23:50 PM

Crosshair V Formula Z
8320 CPU
4gig Gskills ram x2 @ 1200mhz
7870 XFX CORE Edition

System was build in April 2013. Never had any problems with it. Didn't even bother OC'ing.
Today, no video output.
What I've done so far:

reseated the GPU at least 10 times.
Used 4 different monitors (all working) 8 different cables. 2 hdmi. 2 hdmi to DVI, x2VGA to (2 different of these)DVI converter.
Tried two different PSU's. Tested PSU voltage output. PSU is a HX750 Corsair. Running fine. Tested also on a 680 offbrand.
Tested 3 PCI slots. The 4th would smush the headers at the bottom of the board.

Tested the 7870 in a older build. Stress tested it as well, same scores on firestrike as on the other build basically (for video card performance) And also ran longer GPU stress test to see if it was a time factor.

Flashed the CMOS with the latest version with USBFLASHBACK, worked fine but still doesn't see nor power the card.


The card won't even power on the fan. With or without 6pinx2. BIOS isn't showing it under the PCI thing (can't think if what its called now, but it showed the other videocard I put on the board get video output.

WTF is going on?! It'll run a 5850.
The 7870 that runs on two different machines, and performs at 100% what the card should be able to perform at.
But on the Crosshair which its run this 7870 from April 2013 won't even turn on the fan. BTW its not even halting POST. No post code. It boots into bloody windows 8, but without a videocard.

I know its not the Videocard. But the MOBO runs a 5850!

Its still under warranty for over 2 years. So if I have to I'll RMA the damned thing. But someone please save me the month or so of waiting to get a computer back.



I'M NOT SEATING THE CARD WRONG! It seats fine in the other machines. And what are the chances that the 3 other PCI slots which WORK WITH THE 5850 aren't working with the 7870.


I'm at a complete loss. And feel you guys will be as well... Help!







Side note: I'm thinking that its a Southbridge issue, like it doesn't want to give the 7870 the x32 or something and that is causing the card to just not power. But that sounds insane. But really this whole situation is insane.
a b U Graphics card
a b V Motherboard
March 4, 2014 11:18:41 PM

So its almost like the board just refuses to see the 7870 card.
But the card works in other systems.

And the 5870 works on all boards.
And a 680 card works in the Formula Z fine.

It may be in the slot, but is it level in relation or parallel when screwed to the case.
What I mean is it`s not pulling down over and making or breaking from the finger board of the card in the pci-e slots.



Give the gold fingers on the card on each side a light run with an pencil eraser.

It has to be a combination of the 7870 and the slot its self.

That`s about all I can suggest.






m
0
l
March 5, 2014 7:38:16 AM

I've given that a shot, no luck. Assuming running the fingers is just to make sure there isn't any nonconductive filming in the way?

I've kept the case on its side for this build to keep pressure off of the PCI slot, did that some how in the world of crazy cause a issue with the PCI slots? It clearly works with other cards though. This is frustrating hahaha
m
0
l

Best solution

March 5, 2014 12:23:37 PM

Welp that was it. I blasted out all the PCIE Slots with air. Then cleaned them with a microfiber cloth with rubbing alcohol. Along with doing the same for the fingers on the card.

Also I wonder if maybe it something weird with the PCIE Slot locks. But After cleaning the slots and the card. (the Microfiber cloth had no visible stuff on it after cleaning, but I'm not questioning something that fixed things.

Maybe the pins in the slots went funny and me cleaning somehow pushed them back into position.

I'm going to be leaving the case UPRIGHT from now on just incase that had some major adverse effect on the slots. I could understand one going (the one that was in use) but, the 2 others that I could test, that have never been used O.O

I've booted up, stress tested, everything is back to normal, GPUZ is showing under heavy load being in x16 2.0 mode, which is sad, but then again I really don't believe the Crosshair does 3.0 at all.

Welp when in doubt clean those pcie slots... Still insane that the 5850 was getting contact. I've held both cards up close to each other and can't see a difference really at all. But who knows, maybe its a smiggen thicker on the 5850 or something.

This was by far the strangest and yet most simple solution I've ever heard of. Didn't think the PCIE Slot pins could even move.

Makes me wonder if the board isn't defective, but works. Shrug if it comes up again I'll bloody RMA it.

Thanks guys so much again!!!
And hopefully this can help someone else!
Share
!