Asrock 990fx extreme9 usb 2.0 and 3.0 on motherboard wont work just bought it today

Asrock 990fx extreme9 usb 2.0 and 3.0 on motherboard wont work i tried to un install and re install drivers it works off and on....1 second they work next second they dont i just bought it today should i send it back and get a new one or what...I really dont wanna send it back
12 answers Last reply
More about asrock 990fx extreme9 usb motherboard wont work bought today
  1. firstly, Have you updated the BIOS (It won't work if you don't)? and is the CPU compatible?
  2. yes my cpu is compatible fx8350 im on the computer right now but the usb's acted funny they work and then they dont
  3. You have to update the BIOS if you haven't already
  4. ok will try
  5. i've never actually done that before though so how would i go about doing it?
  6. youtube has people to show you step-by-step on how to do it.
  7. ive updated and they are still not working.
  8. trying to reinstall the drivers it says on usb controller no driver found
  9. hmmm, Could you link up your PC specs so I know what we are dealing with here.
  10. yes i can i called asrock but they are no help and the usb 2.0 are working now still not 3.0


    AMD fx8350 with corcair h110,Asrock 990fx extreme 9,8gb G skill 1600mhz ,xfx
    7870 core edition 2gb,corsair 750w psu 128 gb toshiba ssd,windows 7 64bit
  11. should i just sent it back and get a new one
  12. If the 3.0 ports don't work on the back of the motherboard directly, then it is a problem with the motherboard. You'll have to replace it. If this issue is persistent, then the problem may be worse then previously thought.
Ask a new question

Read More

Motherboards ASrock USB