Sign in with
Sign up | Sign in
Your question
Solved

Display ports on my Biostar mobo don't work, but everything else (audio, usb, etc) does

Tags:
  • Motherboards
  • Biostar
  • Displays
Last response: in Motherboards
Share
March 8, 2014 7:59:41 PM

When I plug a display in, it detects it, but it just goes into power save mode, as if the computer is asleep (I've tried this for the DVI-I, VGA and HDMI ports).

All the ports on my gpu work just fine though, so I really have no idea what to do, as I've already updated the drivers for my mobo, and tried to connect a display using ONLY the mobo, rather than a gpu & mobo combo.

Mobo: http://www.newegg.com/Product/Product.aspx?Item=N82E168...

More about : display ports biostar mobo work audio usb

March 18, 2014 8:18:24 PM

bump
m
0
l

Best solution

March 18, 2014 10:07:18 PM

Hold on. Just to make sure everything is clear...

1) Are you talking about an external GPU or do you only have an integrated one? Have you unseated the GPU and tested the monitor directly to the MoBo? Does it work that way? If so, does the monitor not display at all once you plug the display into the GPU port after hardware installation? Do you see it during POST and not OS bootup or just blank from the beginning?

- If nothing at all, I'd go through the settings on the monitor using it's menu function. Also, reseat the memory sticks on your MoBo and test; then also try each stick at a time as well. It's not that common, but I've had cases where bad or unseated RAM have kept video from being displayed from startup.

- if you see an image with the MoBo, then it's BIOS settings, the MoBo PCIe slot, or the GPU. If the display works until bootup, then go into BIOS settings and set the device as default... although it should default to that anyway on most MoBos... If not, go into BIOS when plugged into your MoBo and see if the BIOS setup has an option where it shows the PCIe slot being disabled.

2) What GPU do you have? What about your PSU? It is possible that there is an issue with power or some compatibility issue with the GPU. If you're using an integrated one, this doesn't really matter.

3) Has it ever worked and it's suddenly doing this? Get into BIOS setup by pressing DEL while your computer is starting. Just hold down on the button starting from power on unless you know when to get into setup. Reset your settings to default. Check if that fixed it; then it's a settings issue in your BIOS.

There could be other reasons (including: you sh*t is broken), but I can't assume anything else without more info on the hardware & system.
Share
!