Sign in with
Sign up | Sign in
Your question
Solved

Powerbook G4 won't turn on at all.

Last response: in Mac Os X
Share
March 9, 2014 10:57:59 AM

Alright I have a Powerbook G4 Aluminum 15"
I want to use it and it just refuses to turn on I have no Idea what it is. My guess is that it is a problem with the battery or charger port. When I plug in the charger it gives me a green light which means its charging. I have tried many things to get it to turn on. I left it all night charging and nothing happens when I click the power button. Also the battery has a button that you click on that tells you how much charge it has, Well when I click the button there is no light. I know that you can still use the Powerbook while it is plugged in with charger. My Powerbook doesn't even turn on when it is plugged in. I'm also starting to think this might be a problem with the DC board.
Here is a video showing you my Powerbook
http://youtu.be/mRIE0YT2xLk
Please help!

More about : powerbook turn

March 10, 2014 12:26:29 PM

Check you have the correct power supply, using the wrong one will refuse to work, if it's the right one,
remove the battery, connect the power supply, press and hold the power button for at least 10 seconds; if that doesn't work try holding shift+alt (as far as I remember) then press and hold the power button (for 10 seconds); if that doesn't work it probably needs to be taken to an Apple Store/Repair Centre.
m
0
l

Best solution

March 10, 2014 6:06:08 PM

Thanks Joe i have found my problem. Yes I was using the right power supply. I have tried that as well. My power book has a dent on the charging port. I think that when I made the dent on the charger port I might have damaged the dc in board. Thank you very much for trying to help!!!
I have already ordered the part.
Share
!