Windows 7 is looking for drivers

Hey, everyone,

I did look for this problem, but nobody had the precise problem that I do now and most solutions I found didn't work for me.

I recently purchased system components from Newegg:
Apevia Qboii Case
16GB RAM from Corsair (1866mhz)
AMD A10-7850K Kaveri APU
Asus A88XM-A Motherboard
WD 1TB HDD

I had an issue with the power supply earlier but that is now resolved. My main problem now is as follows.
Turning on the computer gets a standard boot screen and hitting F2 gets you a nice bios. I selected my Windows 7 OEM dvd (also from Newegg) and restarted to boot. A Windows 7 installation screen comes up and gives you the language and keyboard options and you can then "Install Now". Clicking this gets you a setup screen that says "Starting Setup". Ten seconds later, a screen pops up with "Drivers not found" and then tells me to browse and insert media with those drivers. I've downloaded SATA mobo drivers from Asus and put those in several times and with no luck.

I then found a friend with a retail copy of windows 7 from when it was the latest and greatest. I figured I could use his dvd and my product key (he was out of installs on his). This resulted in the exact same problem.

One thing that was consistent with my other forum searching was that it was an issue with SATA. I don't know how true this is, but I tried changing SATA cables, different sata spots on the motherboard and different power supply ends. All produced the same result.

I've been trying to come up with what this could possibly mean. Normally I'm a mac guy but had some extra cash lying around and since not a lot of games are available for OS X, I decided to build this system. Bios stats show that I've installed everything right and it doesn't seem like a hardware problem, because if it is SATA it stops having drivers after windows installation starts.

Thanks for any and all suggestions; I've spent so much time scouring the web for drivers and answers.

--Calvin
1 answer Last reply
More about windows drivers
  1. you can try bios update of your motherboard or simple try clearing CMOS.
Ask a new question

Read More

Windows 7 Drivers